Bug 114691 - Support for IPv6 router advertisement not enabled
Support for IPv6 router advertisement not enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: quagga (Show other bugs)
1
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-31 10:52 EST by Ernest Neijenhuis
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 14:02:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ernest Neijenhuis 2004-01-31 10:52:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I upgraded from Red Hat Linux 8.0 to Fedora Core 1. On RH8 I used 
zebra for IPv6 router advertisement. In Fedora the zebra package has 
been replaced by the quagga package, which includes zebra aswell. 
Unfortunately the new zebra isn't able to do broadcast IPv6 router 
advertisements anymore.

Version-Release number of selected component (if applicable):
quagga-0.96.4-0.fc1

How reproducible:
Always

Steps to Reproduce:
1. Configure IPv6 router advertisement in /etc/quagga/zebra.conf:
(...)
interface eth0
 ipv6 address 2001:888:1083:100::1/64
 no ipv6 nd suppress-ra
 ipv6 nd prefix-advertisement 2001:888:1083:100::/64
(...)

2. Reload the zebra configuration:
odie# service zebra reload


Actual Results:  The following messages appear after starting zebra:

Starting zebra: Nothing to flush.
There is no such command.
Error occured during reading below line.
 no ipv6 nd suppress-ra
[FAILED]


Expected Results:  It should not report any error messages regarding 
to IPv6 router advertisement. Also, I should expect to see Router 
Advertisements on my network whenever a new IPv6 host boots.

Additional info:

I found a solution for this downgraded functionality:

I downloaded and installed the quagga source RPM, and added the 
option "--enable-rtadv" to the configure command (lines 105-151 in 
the spec file). After building and installing the RPM the IPv6 router 
advertisement meganism works.
Comment 1 Need Real Name 2004-03-15 20:05:35 EST
Same for me, ipv6 support not enabled, but i think it should be :)
Comment 2 Jay Fenlason 2004-12-07 14:02:06 EST
Looks like this got fixed a while ago. 

Note You need to log in before you can comment on or make changes to this bug.