Bug 114703 - Support for -m32 switch is not available for GCC suite.
Support for -m32 switch is not available for GCC suite.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-31 17:39 EST by Dave
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 15:32:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2004-01-31 17:39:09 EST
Description of problem:

It appears that support for the -m32 switch is not available for the
GCC suite in current the FC 1 x86_64 (test1) installation. 

IMHO, this is important (and should probably be installed by default
when the "Development Tools" selection is made during installation)
because there is probably going to be a lot of non-x86_64 compatible
i386 source code to build for a long time to come ;).

Version-Release number of selected component (if applicable):


How reproducible:

Try compiling any C/C++ source code with the -m32 switch on FC1 x86_64
(test1).

Steps to Reproduce:
1. See above.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gene Czarcinski 2004-02-09 07:26:24 EST
Strange ... it worked fine for me (gcc 3.3.2-6) doing a simple "hello"
c program.
Comment 2 Jakub Jelinek 2004-02-13 10:37:04 EST
Do you have glibc-2.3.*.i686.rpm and glibc-devel-2.3.*.i386.rpm installed?
Comment 3 Gene Czarcinski 2004-02-13 11:12:00 EST
If it is the lack of glibc-devel...i386.rpm, then this should be
against distribution as glibc-devel (i386) is not part of the
"standard" set of packages.
Comment 4 Dave 2004-02-17 14:36:26 EST
# rpm -qa | grep glibc
glibc-2.3.2-101.1
glibc-common-2.3.2-101.1
glibc-devel-2.3.2-101.1
glibc-headers-2.3.2-101.1
glibc-2.3.2-101.1
glibc-kernheaders-2.4-8.36

when I compile a simple Hello World with -m32, I get the following:

/usr/bin/ld: cannot open crt1.o: No such file or directory
collect2: ld returned 1 exit status

crt1.o can only be found in /usr/lib64 on this machine.
Comment 5 Justin M. Forbes 2004-02-17 14:44:00 EST
glibc-devel 32bit should be included in the next release.  Sorry about
that one.
Comment 6 Dave 2004-02-17 17:24:02 EST
Thank you, and to all for all of your collective work on this and
forthcoming releases. All-in-all this release has been working very
nicely on this hardware.
Comment 7 Richard Henderson 2004-10-04 15:32:24 EDT
All the 32 bit stuff is present in FC2.

Note You need to log in before you can comment on or make changes to this bug.