Bug 114708 - Evolution crashes at start after upgrade to evolution-1.5.3-1.i386.rpm
Evolution crashes at start after upgrade to evolution-1.5.3-1.i386.rpm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-31 21:21 EST by Rob Hughes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 14:20:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Hughes 2004-01-31 21:21:41 EST
Description of problem:
Evolution crashes at start after upgrade to evolution-1.5.3-1 on
Fedora Core 1

Version-Release number of selected component (if applicable):
evolution-data-server-0.0.6-1.i386.rpm
gtkhtml3-3.1.7-1.i386.rpm
libgal2-2.1.4-1.i386.rpm
libsoup-2.1.5-1.i386.rpm
evolution-1.5.3-1.i386.rpm

How reproducible:
ALways

Steps to Reproduce:
1. upgrade the following packages to satisfy depencies:
evolution-data-server-0.0.6-1.i386.rpm
gtkhtml3-3.1.7-1.i386.rpm
libgal2-2.1.4-1.i386.rpm
libsoup-2.1.5-1.i386.rpm
evolution-1.5.3-1.i386.rpm
2. Try to start evolution
3.
    
  
Actual results:
Evolution fails to import inbox, then crashes at start

Expected results:
Evolution imports inbox, then starts

Additional info:
Comment 1 Rob Hughes 2004-01-31 21:22:06 EST
Debugging Information:

Backtrace was generated from '/usr/bin/evolution'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[Thread
debugging using libthread_db enabled]
[New Thread -1084620672 (LWP 3008)]
[New Thread 106806192 (LWP 3019)]
[New Thread 84765616 (LWP 3017)]
[New Thread 149363632 (LWP 3016)]
[New Thread 70593456 (LWP 3015)]
[New Thread 27012016 (LWP 3014)]

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x00101c32 in _dl_sysinfo_int80 ()
   from /lib/ld-linux.so.2
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00871b2b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x038b57f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
#3  0x08063581 in e_user_creatable_items_handler_get_type ()
#4  <signal handler called>
#5  0x421717fd in e_canvas_item_grab_focus () from
/usr/lib/libgal-2.2.so.0
#6  0x00b03b33 in g_timeout_add () from /usr/lib/libglib-2.0.so.0
#7  0x00b00fdd in unblock_source () from /usr/lib/libglib-2.0.so.0
#8  0x00b01fd8 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#9  0x00b022ef in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#10 0x00b029cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#11 0x0366d8c6 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#12 0x08063966 in main ()

Thread 6 (Thread 27012016 (LWP 3014)):
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0086e424 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4257131d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x42571bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0086b7fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006dbaba in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 5 (Thread 70593456 (LWP 3015)):
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0086e424 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4257131d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x42571bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0086b7fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006dbaba in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 4 (Thread 149363632 (LWP 3016)):
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0086e424 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4257131d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x42571bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0086b7fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006dbaba in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 3 (Thread 84765616 (LWP 3017)):
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0086e424 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4257131d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x42571bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0086b7fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006dbaba in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 2 (Thread 106806192 (LWP 3019)):
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0086e424 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4257131d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x42571bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0086b7fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006dbaba in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 1 (Thread -1084620672 (LWP 3008)):
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x00871b2b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x038b57f4 in libgnomeui_module_info_get () from
/usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x08063581 in e_user_creatable_items_handler_get_type ()
No symbol table info available.
#4  <signal handler called>
No symbol table info available.
#5  0x421717fd in e_canvas_item_grab_focus () from
/usr/lib/libgal-2.2.so.0
No symbol table info available.
#6  0x00b03b33 in g_timeout_add () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x00b00fdd in unblock_source () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x00b01fd8 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x00b022ef in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x00b029cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#11 0x0366d8c6 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#12 0x08063966 in main ()
No symbol table info available.
#0  0x00101c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2


Comment 2 Rob Hughes 2004-02-01 00:25:38 EST
I can also confirm that this happens for all users on the system.
Comment 3 Laura 2004-02-01 11:01:18 EST
i had the same problems, related to "undefined symbol: 
gdk_thread_lock" in libgtkhtml-3. After i tried to undo prelink and 
prelink again like in the another bug, i had to rebuild from src.rpm 
and now it works perfectly. 

maybe it is compiled on a different version of gtk ?
Comment 4 Rob Hughes 2004-02-01 11:13:13 EST
If it is, it should list that version in the dependencies, but I'll 
give that a whirl and see. 
Comment 5 Rohan Durrant 2004-02-23 07:51:49 EST
I just upgraded to the latest gtk2 rpm from the fedora devel tree 

gtk2-2.3.2-3.rpm 

and the dependancy on LibXinerama went away :) 
Comment 6 Rob Hughes 2004-02-23 08:32:47 EST
I ended up downgrading to 1.4.5. I almost got it running, but could 
never get 1.5 stable. 
Comment 7 Dave Malcolm 2004-09-21 14:00:15 EDT
I'm sorry that this bug has gone for so long without activity.

Have you tried with more recent versions of evolution-1.5.* ? 
evolution-2.0.0 is now available in Rawhide
Comment 8 Rob Hughes 2004-09-25 17:31:49 EDT
The 1.5.x series got better, but still crashed when trying to import
mail dirs with large (>100) numbers of messages when starting for the
first time. The rawhide mirror I use finally sync'ed up, so I'll try
2.0 and see how that does.
Comment 9 Dave Malcolm 2004-11-01 14:20:40 EST
I'm going to close this particular bug, since it refers to such an old
version of the 1.5 branch of Evolution; the backtrace is highly
unlikely to be relevant any more, I'm afraid.   

So I'm going to close this particular bug as WONTFIX (since I have no
plans to make evolution 1.5.3 work better).  

However, I'm _very_ interested in hearing about problems with
migration to the latest version of Evolution (from 1.4 to 2.0), so
please do file them in bugzilla if you encounter any.

Note You need to log in before you can comment on or make changes to this bug.