Bug 114716 - prelink can't prelink Xlibs
prelink can't prelink Xlibs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-01 04:39 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 10:02:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-02-01 04:39:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When i try to compile anything which uses X i get errors like
"/usr/lib/gcc-lib/i386-redhat-linux/3.2.3/../../../libgdk-x11-2.0.so:
undefined reference to `XFreePixmap'" (i have used the correct flags)
i thought maybe prelink is causing this so i runed it manually
/usr/sbin/prelink -av
but i got this erros:
/usr/sbin/prelink: "/usr/X11R6/lib/libXext.so.6" has no section headers
/usr/sbin/prelink: "/usr/X11R6/lib/libX11.so.6" has no section headers 
and many cannot prelink xx because /usr/X11R6/lib/libXext.so.6 can not
be prelinked.


Version-Release number of selected component (if applicable):
prelink-0.3.0-13

How reproducible:
Always

Steps to Reproduce:
i have not tested it on an othere machine but on mine it happens when
i run prelink
    

Actual Results:  i got this errormsg:
/usr/sbin/prelink: "/usr/X11R6/lib/libXext.so.6" has no section headers
/usr/sbin/prelink: "/usr/X11R6/lib/libX11.so.6" has no section headers

Expected Results:  it should prelink the X11 libs.

Additional info:

Here are the versions of my XFree86 libs:
XFree86-truetype-fonts-4.3.0-42
XFree86-xfs-4.3.0-42
XFree86-base-fonts-4.3.0-42
XFree86-tools-4.3.0-42
XFree86-devel-4.3.0-42
XFree86-libs-data-4.3.0-42
XFree86-4.3.0-42
XFree86-xdm-4.3.0-42
XFree86-libs-4.3.0-42
XFree86-xauth-4.3.0-42
XFree86-100dpi-fonts-4.3.0-42
XFree86-twm-4.3.0-42
XFree86-font-utils-4.3.0-42
XFree86-75dpi-fonts-4.3.0-42
XFree86-Mesa-libGL-4.3.0-42
XFree86-Mesa-libGLU-4.3.0-42
and i have installed the nvidia drivers
Comment 1 Need Real Name 2004-02-02 10:37:00 EST
i have reinstalled XFree86-libs and this seems to have fixed the
problem ;)

Note You need to log in before you can comment on or make changes to this bug.