Bug 114721 - Bad font causes application crash (integer out of range)
Bad font causes application crash (integer out of range)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-01 10:42 EST by Tethys
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-28 17:56:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2004-02-01 10:42:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
This manifests itself in GIMP, but I'm fairly sure it's an underlying
problem with GDK. When using the font selector, pick the City Slicker
true type font. As soon as it's selected, GIMP crashes with the
following error:

leto:~% gimp
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
  serial 21266 error_code 2 request_code 45 minor_code 0

LibGimp-WARNING **: script-fu: wire_read: unexpected EOF

City Slicker isn't shipped by default with FC1, but is widely
available on the net. I've put the copy I'm using up on my web
site at http://www.astradyne.co.uk/bugs/fedora/citys___.ttf

I don't know whether this font file is corrupt or in some other
way broken. But even if it is, it shouldn't cause the application
to die.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-28.1

How reproducible:
Always

Steps to Reproduce:
1. Install city slicker font
2. Start GIMP, open a new image, and select the text tool
3. Click in the image. The text tool dialog appears. Select City
   Slicker from the list of fonts.
    

Actual Results:  Application exits with the above error message

Expected Results:  Font should be used, or an error displayed if it's
corrupt

Additional info:
Comment 1 Matthias Clasen 2004-08-28 13:56:20 EDT
If anything, this is a problem in the gimp text tool. It is
definitively not a problem with gtk 1.2, since gimp uses gtk 2.0. I
can't reproduce this with the gimp in fc3. Reassigning to gimp.
Comment 2 Tethys 2004-08-28 17:56:46 EDT
Yep, whatever the problem was, it's gone now, so I'm happy for this to
be closed.

Note You need to log in before you can comment on or make changes to this bug.