Bug 114726 - Same Sendmail.conf for sasl and sasl2
Same Sendmail.conf for sasl and sasl2
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-01 14:57 EST by Robert Scheck
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 09:48:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-02-01 14:57:02 EST
Description of problem, how reproducible and steps to reproduce:
After a build of Sendmail from Fedora Development, I noticed

"sendmail[21473]: unrecognized plaintext verifier saslauthd"

in my syslog, because I built Sendmail only with sasl and not with 
sasl2 support.

So I located the problem and found

/usr/lib/sasl2/Sendmail.conf: pwcheck_method:saslauthd

and also:

/usr/lib/sasl/Sendmail.conf: pwcheck_method:saslauthd

I changed /usr/lib/sasl/Sendmail.conf's content to "pwcheck_method:
pam"

and all works fine, now.

Version-Release number of selected component (if applicable):
sendmail-8.12.11-2

Actual results/Expected results:
In the spec file, I saw, that you use the same "Sendmail.conf" for 
sasl and sasl2...maybe you introduce a second "Sendmail.conf" with 
"pwcheck_method:pam" for sasl1?
Comment 1 Thomas Woerner 2004-02-19 09:48:50 EST
Fixed in rawhide in rpm sendmail-8.12.11-3.2 or newer.

Note You need to log in before you can comment on or make changes to this bug.