Bug 114761 - Missing dpt_i2o driver in all hugemem kernels
Missing dpt_i2o driver in all hugemem kernels
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-02 10:45 EST by Bruno Verkist
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-02 16:04:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Verkist 2004-02-02 10:45:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
dpt_i2o driver is missing in all hugemem kernels:

kernel-hugemem-2.4.21-4.EL
kernel-hugemem-2.4.21-4.0.1.EL
kernel-hugemem-2.4.21-4.0.2.EL
kernel-hugemem-2.4.21-9.EL

If a hugemem kernel is installed on a system with an Adaptec 3200
controller the installation will fail due to the following mkinitrd error:

[root@import 2.4.21-4.0.1]# rpm -ivh
kernel-hugemem-2.4.21-4.0.1.EL.i686.rpm
warning: kernel-hugemem-2.4.21-4.0.1.EL.i686.rpm: V3 DSA signature: 
NOKEY, key ID db42a60e
Preparing...                ########################################### 
[100%]
   1:kernel-hugemem         ########################################### 
[100%]
No module dpt_i2o found for kernel 2.4.21-4.0.1.ELhugemem, aborting.
mkinitrd failed
error: %post(kernel-hugemem-2.4.21-4.0.1.EL) scriptlet failed, exit
status 1 [root@import 2.4.21-4.0.1]#

Version-Release number of selected component (if applicable):
kernel-hugemem-2.4.21-4.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1. Install hugemem kernel on Primergy RX800 with RHEL 3 installed, e. g. :
rpm -ivh kernel-hugemem-2.4.21-4.0.1.EL.i686.rpm

2. ---

3. ---
    

Actual Results:  warning: kernel-hugemem-2.4.21-4.0.1.EL.i686.rpm: V3
DSA signature: 
NOKEY, key ID db42a60e
Preparing...                ########################################### 
[100%]
   1:kernel-hugemem         ########################################### 
[100%]
No module dpt_i2o found for kernel 2.4.21-4.0.1.ELhugemem, aborting.
mkinitrd failed
error: %post(kernel-hugemem-2.4.21-4.0.1.EL) scriptlet failed, exit
status 1 [root@import 2.4.21-4.0.1]#

Expected Results:  Installation of
kernel-hugemem-2.4.21-4.0.1.EL.i686.rpm should have completed without
an error; mkinitrd should have built a new
initrd-2.4.21-4.0.1ELhugemem.img.

Additional info:
Comment 1 Arjan van de Ven 2004-02-02 16:04:30 EST
it's in kernel-hugemem-unsupported

Note You need to log in before you can comment on or make changes to this bug.