Bug 114778 - (IT_40613) tight SCSI DMA pool due to incorrect resizing
tight SCSI DMA pool due to incorrect resizing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2004-02-02 14:59 EST by Martin Peschke
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:31:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problem fix (777 bytes, patch)
2004-02-02 15:02 EST, Martin Peschke
no flags Details | Diff

  None (edit)
Description Martin Peschke 2004-02-02 14:59:23 EST
(as reported on linux-scsi)

While running extensive SCSI tests with SUSE kernels and the zfcp
driver we hit bugs which stem from the vanilla 2.4 kernel.
This particular problem causes unnecessary memory constraints
in the SCSI subsystem. The SCSI midlayer holds out a pool of
upto 32 MB which is the exclusive memory source for SCSI operation.
Due to a faulty calculation 2.4 kernels might end up with a
fraction amount. This has been especially observed with large
SCSI configurations which demand more than 32 MB, and which
are in turn hit hardest.
This patch has been blessed by Jens Axboe, Mike Anderson,
and Kurt Garloff, who helped straightening this out.
Comment 1 Martin Peschke 2004-02-02 15:02:31 EST
Created attachment 97413 [details]
problem fix

as posted on linux-scsi
http://marc.theaimsgroup.com/?l=linux-scsi&m=107574374710116&w=2
Comment 2 Doug Ledford 2004-05-12 12:05:58 EDT
Patch integrated into test kernel.
Comment 5 Ernie Petrides 2004-06-05 00:37:00 EDT
A fix for this problem has been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-15.6.EL).
Comment 6 Don Howard 2004-06-09 16:36:34 EDT
Adding to u3 blocker for tracking. 
Comment 8 Jay Turner 2004-08-17 12:04:25 EDT
Moving back to assigned, as it appears there are still issues with the
patch.
Comment 12 Martin Peschke 2004-08-25 07:44:04 EDT
Any details at hand?
Comment 13 Tim Burke 2004-08-26 14:40:33 EDT
This patch is included in the RHEL3 U3 kernel 2.4.21-20 and later. 
Comment 14 John Flanagan 2004-09-02 00:31:02 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.