Bug 114849 - language selection broken
language selection broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: transfig (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 11:03 EST by Ulrich Seidl
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 16:38:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Seidl 2004-02-03 11:03:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
When selecting pstex as output language, transfig generates a makefile
for psfig languague. The problem is the different mapping of languages
in transfig.c (lname[]) and transfig.h (enum language).

Patch of transfig.c follows:

diff -ru transfig.3.2.4/transfig/transfig.c
transfig.3.2.4-pstex/transfig/transfig.c
--- transfig.3.2.4/transfig/transfig.c  2002-12-18 23:34:12.000000000
+0100
+++ transfig.3.2.4-pstex/transfig/transfig.c    2004-02-03
16:22:25.000000000 +0100
@@ -64,6 +64,7 @@
                "png",
                "ppm",
                "ps",
+               "psfig",
                "pstex",
                "ptk",
                "sld",


Version-Release number of selected component (if applicable):
3.2.4-5

How reproducible:
Always

Steps to Reproduce:
1. transfig -L pstex -M FIGmake xyz.fig
2. see FIGmake
3.
    

Additional info:
Comment 1 Ngo Than 2004-11-30 16:38:43 EST
it's now fixed in 3.2.4-10 or newer. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.