Bug 114866 - Invalid test in startup script
Invalid test in startup script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 13:50 EST by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.1.25-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-04 19:20:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2004-02-03 13:50:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)
Gecko/20040118

Description of problem:
The /etc/init.d/ldap script contains currently in line 41:

find ${dbdir}/ -not -uid $ldapuid -and -name "*.dbb" -or -name
"*.gdbm" -or -name "*.bdb"

This is bogus since the precendence groups the ID test with the first
name test.


Version-Release number of selected component (if applicable):
openldap-2.1.25-1

How reproducible:
Always

Steps to Reproduce:
1.make sure /var/lib/ldap contains files XXX.bdb with ID ldap/ldap
2.run script
3.
    

Actual Results:  Warning about files not being owned by ldap

Expected Results:  No warnings

Additional info:

Use

find ${dbdir}/ -not -uid $ldapuid -and \( -name "*.dbb" -or -name
"*.gdbm" -or -name "*.bdb" \)

See the additional \( \)
Comment 1 Nalin Dahyabhai 2004-02-03 14:30:24 EST
Thanks!

Note You need to log in before you can comment on or make changes to this bug.