Bug 114881 - Apply Alternate Workflow permission broken
Apply Alternate Workflow permission broken
Status: CLOSED WONTFIX
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-03 18:03 EST by Jon Orris
Modified: 2007-04-18 13:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 10:46:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2004-02-03 18:03:28 EST
Description of problem:

@40017/Oracle-se

The Apply Alternate workflow permission seems to be broken.
To Reproduce:
I create a new workflow in addition to 'Production Workflow'
The first task is assigned to the Authoring role.
The Authoring Role is granted Apply Alternate Workflow permission.
The user in the authoring role creates an item.
No selection for workflow appears.

Log4j debug of permissions service when creating the item.

2004-02-03 18:03:31,360 [4][6]] DEBUG permissions.PermissionService -
checking read on [com.arsdigita.cms.ContentSection:{id=69}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,372 [4][6]] DEBUG permissions.PermissionService -
checking cms_staff_admin on [com.arsdigita.cms.ContentSection:{id=69}]
for [com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,393 [4][6]] DEBUG permissions.PermissionService -
checking cms_new_item on [com.arsdigita.cms.Folder:{id=65}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,405 [4][6]] DEBUG permissions.PermissionService -
checking cms_edit_item on [com.arsdigita.cms.Folder:{id=65}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,424 [4][6]] DEBUG permissions.PermissionService -
checking cms_item_admin on [com.arsdigita.cms.Folder:{id=65}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,444 [4][6]] DEBUG permissions.PermissionService -
checking admin on [com.arsdigita.cms.Folder:{id=65}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,458 [4][6]] DEBUG permissions.PermissionService -
checking cms_delete_item on [com.arsdigita.cms.Folder:{id=65}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,466 [4][6]] DEBUG permissions.PermissionService -
checking cms_lifecycle_admin on
[com.arsdigita.cms.ContentSection:{id=69}] for
[com.arsdigita.kernel.User:{id=269}]
2004-02-03 18:03:31,618 [4][6]] DEBUG permissions.PermissionService -
checking cms_apply_alternate_workflows on
[com.arsdigita.cms.Folder:{id=65}] for
[com.arsdigita.kernel.User:{id=269}]
Comment 1 Scott Seago 2004-02-05 11:47:52 EST
Jon, this turned out to be not a bug, right? (since you had customized
folder permissions before adding the new permission to your role)

Note You need to log in before you can comment on or make changes to this bug.