This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 114917 - mozilla-1.4.1 rpm : brokem MathML support
mozilla-1.4.1 rpm : brokem MathML support
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
http://www.mozilla.org/projects/mathm...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 10:05 EST by Jungshik Shin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 14:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jungshik Shin 2004-02-04 10:05:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040113

Description of problem:
For MathML rendering, Mozilla-Xft relies on fontEncoding.properties
file.  The file that comes with mozilla-1.4.1-18 for Fedora Core1
(/usr/lib/mozilla-1.4.1/res/fonts/fontEncoding.properties) is a broken
symbolic link to an unexisting file. It seems like it's not copied but
was made a symbolic link during the build process. 



Version-Release number of selected component (if applicable):
mozilla-1.4.1-18

How reproducible:
Always

Steps to Reproduce:
1. go to /usr/lib/mozilla-1.4.1/res/fonts
2. run 'ls -l' 


Alternative: 
1. Add Adobe Symbol (postscript type 1) font to ~/.fonts (or any of
global font directories)
2. Download truetype version of Computer Modern fonts and Mathematica
4.1 fonts (see the instruction at
http://www.mozilla.org/projects/mathml/font)  
3. Lanuch Mozilla
4. Point the browser to the URL given in the URL field
5. MathML rendering is broken
    

Actual Results:  fontEncoding.properties file is a broken link to an
unexisting file

alternative:

MathML is not rendered correctly


Expected Results:  fontEncoding.properties file is an actual file (not
a link) with the content

alternative:

MathML is rendered nicely

Additional info:

For more details, see http://bugzilla.mozilla.org/show_bug.cgi?id=120198
comment #68
Comment 1 Jungshik Shin 2004-02-05 04:29:47 EST
I'm to blame for this bug. See the following comments in mozilla
bugzilla for details:

http://bugzilla.mozilla.org/show_bug.cgi?id=120198#c77
http://bugzilla.mozilla.org/show_bug.cgi?id=176290#c140

http://bugzilla.mozilla.org/attachment.cgi?id=126983 (the patch to
apply to 1.4.x rpm build)

Comment 2 Christopher Blizzard 2004-02-12 14:15:01 EST
Marking UPSTREAM since we're going to be pulling in 1.4.2 eventually.

Note You need to log in before you can comment on or make changes to this bug.