Bug 114931 - satellite-sync hangs
Summary: satellite-sync hangs
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Chris Runge
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 111817
TreeView+ depends on / blocked
 
Reported: 2004-02-04 17:02 UTC by Chris Runge
Modified: 2007-07-31 14:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 19:51:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of satellite-debug at time of hang (492.32 KB, text/plain)
2004-02-04 17:03 UTC, Chris Runge
no flags Details
output of satellite-debug at time of hang (492.32 KB, application/x-bzip2)
2004-02-04 17:03 UTC, Chris Runge
no flags Details

Description Chris Runge 2004-02-04 17:02:28 UTC
Description of problem:

satellite-sync has a random tendency to hang. There is no visible
indication of the reason for this. CTRL-C is unable to break out of
the hang. The satellite-sync process must be identified and manually
killed before restarting.

The problem is random. This past weekend while syncing the RHEL 3
WS/AS trees it happened every hour or so. A sync of the RHEL 2.1 AS
tree last night/today had no hangs.

Version-Release number of selected component (if applicable):

rhn-satellite-3.0.9-11

How reproducible:

difficult to reproduce with any consistency

Comment 1 Chris Runge 2004-02-04 17:03:54 UTC
Created attachment 97468 [details]
output of satellite-debug at time of hang

I captured this satellite-debug output when the satellite-sync was hung

Comment 2 Chris Runge 2004-02-04 17:03:59 UTC
Created attachment 97469 [details]
output of satellite-debug at time of hang

I captured this satellite-debug output when the satellite-sync was hung

Comment 3 Mihai Ibanescu 2004-02-05 18:13:12 UTC
Chris, whenever this happens again, can you try to find the PID of the
satellite-sync process and then send us the output of:

strace -p <PID>
lsof -p <PID>

Being difficult to reproduce, I'll have to try and figure out what's
going on...

Comment 4 Greg DeKoenigsberg 2004-03-02 22:16:10 UTC
Let's keep an eye on this going forward.

Comment 5 Chris Runge 2004-04-01 13:49:10 UTC
I haven't had this problem as of yet with the 3.2-10 installer.

Comment 6 Greg DeKoenigsberg 2004-04-02 14:17:28 UTC
We'll leave this open for a while.

Comment 7 Chris Runge 2004-04-21 19:51:30 UTC
closing... I haven't seen this in the 3.2 GA version


Note You need to log in before you can comment on or make changes to this bug.