Bug 114933 - LD_ASSUME_KERNEL does not work under test1
Summary: LD_ASSUME_KERNEL does not work under test1
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-04 17:05 UTC by Ken Snider
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 12:31:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken Snider 2004-02-04 17:05:51 UTC
If I set LD_ASSUME_KERNEL=2.2.5 I get the following odd errors (and
this is with any binary, not just dmesg in the example below:

[ksnider@dw1.dw ksnider]$ ldd `which uname`
        libc.so.6 => /lib64/tls/libc.so.6 (0x0000003f53000000)
        /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2
(0x0000003f52e00000)
[ksnider@dw1.dw ksnider]$ uname -a
Linux dw1.dw 2.4.22-1.2135.nptlsmp #1 SMP Mon Dec 15 15:45:38 EST 2003
x86_64 x86_64 x86_64 GNU/Linux
[ksnider@dw1.dw ksnider]$ export LD_ASSUME_KERNEL=2.2.5
[ksnider@dw1.dw ksnider]$ uname -a
uname: error while loading shared libraries: libc.so.6: cannot open
shared object file: No such file or directory
[ksnider@dw1.dw ksnider]$ unset LD_ASSUME_KERNEL
[ksnider@dw1.dw ksnider]$ uname -a
Linux dw1.dw 2.4.22-1.2135.nptlsmp #1 SMP Mon Dec 15 15:45:38 EST 2003
x86_64 x86_64 x86_64 GNU/Linux

Very odd, looks like something is munging the LD_LIBRARY_PATH perhaps
with NPTL disabled?

Version-Release number of selected component (if applicable):
glibc-2.3.2-101.1

How reproducible:
Always

Comment 1 Jakub Jelinek 2004-02-09 12:31:08 UTC
Why is that surprising? 64-bit libc.so obviously doesn't support
2.2.5 kernel, it doesn't support anything older than 2.4.0.
If you want to use linuxthreads 64-bit, you need LD_ASSUME_KERNEL=2.4.1
up to 2.4.19, and if you for some reason need for some 32-bit program
the old !FLOATING_STACKS 32-bit linuxthreads, you need to ensure
it will be only that program with that env variable and not any
64-bit program.


Note You need to log in before you can comment on or make changes to this bug.