Bug 114962 - breaks pkg-config list due to incomplete dependencies
breaks pkg-config list due to incomplete dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gok (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 16:36 EST by Michael Schwendt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.11.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-18 16:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2004-02-04 16:36:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The "gok" package installs /usr/lib/pkgconfig/gok-1.0.pc, but doesn't
pull in the dependencies which are listed in that pkg-config file (all
*-devel packages). This breaks queries, such as "pkg-config --list-all":

  Package libgnomeui-2.0 was not found in the pkg-config search path.
  Perhaps you should add the directory containing `libgnomeui-2.0.pc'
  to the PKG_CONFIG_PATH environment variable
  Package 'libgnomeui-2.0', required by 'Gok', not found

Where pkg-config --list-all is needed, the only way out is to either
determine and install manually what's missing or to uninstall "gok".

[...]

Is gok-1.0.pc of any use right now and why is it included in a
non-devel package? Its Libs and Cflags fields don't define anything
useful.


Version-Release number of selected component (if applicable):
gok-0.7.1-4

How reproducible:
Always
Comment 1 Simon Bates 2004-04-08 12:17:58 EDT
Hi Michael,

I'm one of the gok developers and I would like to help you fix this
problem. I am fairly inexperienced concerning pkg-config but let me
have a go at guessing what the problem is:

1. the gok RPM contains a gok.pc file
2. the gok.pc file states gok's requirements
3. the .pc files for the libraries that gok depends on are in -devel RPMs
4. the gok RPM does not have -devel RPMs as dependencies

If I am understanding this correctly then we have a couple of options:

1. remove the gok.pc file from the gok RPM

OR

2. remove the gok.pc file completely from the gok source

Please let me know what you think and what we, the gok developers, can
do to address this.

Thanks!
Simon
Comment 2 Michael Schwendt 2004-04-08 14:05:27 EDT
$ rpmpkgcfgcheck.pl gok-0.7.1-4.i386.rpm 
Requires: gtk2-devel
Requires: at-spi-devel
Requires: libgnomeui-devel
Requires: gail-devel
Requires: atk-devel
Requires: libwnck-devel
Requires: esound-devel
Requires: libbonobo-devel

[...]

> 1. the gok RPM contains a gok.pc file

yes, and I wonder what its purpose is when "pkg-config gok-1.0 --libs
--cflags" doesn't return anything useful and there are no gok library
or gok headers included either

> 2. the gok.pc file states gok's requirements

which I find unusual, since its "Libs" entry points to /usr/lib, which
is part of standard linker search path, and its "Cflags" entry points
to a non-existant /usr/include/gok-1.0 directory

> 3. the .pc files for the libraries that gok depends on are in -devel
> RPMs

yes, and gok-1.0.pc should be put into a gok-devel rpm, too, because
it is of no use for a non-devel package

> 4. the gok RPM does not have -devel RPMs as dependencies

which is correct. it shouldn't depend on -devel packages

Note You need to log in before you can comment on or make changes to this bug.