Bug 11506 - xfig incompatible with transfig, other problems
xfig incompatible with transfig, other problems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xfig (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-18 13:27 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-24 15:28:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new spec file (2.94 KB, text/plain)
2000-05-18 13:27 EDT, Jonathan Kamens
no flags Details
new Imakefile patch (6.43 KB, patch)
2000-05-18 13:28 EDT, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2000-05-18 13:27:27 EDT
The xfig spec file claims that it requires transfig 3.2.1 or later. In
fact, xfig 3.2.3 requires transfig 3.2.3 or later, and xfig in RedHat 6.2
therefore cannot properly export using transfig.

Furthermore, the current released version of xfig is 3.2.3a.

Furthermore, the spec file should list the canonical source location, not
www.xfig.org, which is NOT the canonical location since it isn't maintained
by the maintainer of xfig.

Furthermore, the Imakefile patch needs to be updated for 3.2.3a.

Furthermore, the Imakefile patch uses "$(DESTDIR)/" in a lot of places
where it should use "$(DESTDIR)" (i.e., no slash between $(DESTDIR) and
what it is prepended to, since whatever it is prepended to will start with
a slash).

I am going to attach a new spec file and a new Imakefile patch.  You will
need to change the "Release" line in the spec file, but other than that it
should be fine.  You will also need to upgrade transfig; I'll submit that
as a separate bug report.
Comment 1 Jonathan Kamens 2000-05-18 13:27:59 EDT
Created attachment 249 [details]
new spec file
Comment 2 Jonathan Kamens 2000-05-18 13:28:59 EDT
Created attachment 250 [details]
new Imakefile patch
Comment 3 Preston Brown 2000-05-24 15:28:59 EDT
a transfig update was issues for 6.2, I will incorporate the other patches for
our next release.  Thank you.
Comment 4 Ngo Than 2000-06-03 07:58:45 EDT
i have cleanup specfile. xfig requires now transfig-3.2.3 or newer

Note You need to log in before you can comment on or make changes to this bug.