Bug 115071 - [raidtools]Linux device number bug report
[raidtools]Linux device number bug report
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: raidtools (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 22:45 EST by yjwei
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 18:04:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description yjwei 2004-02-05 22:45:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; MyIE2; 
i-NavFourF)

Description of problem:
I have some questions about device number extension.

In Linux kernel 2.6, device number will be extended from 16-bit to 32-
bit.
All utilities and libraries should make corresponding extension for 
this new
feature in kernel 2.6.

I find that "raidtools-1.00.3-7" uses structure dev_t and operates the
device number as 16-bit.
---------------------------------------------------------------------

lsraid.c line 59:

#define MAJORBITS 8
#define MINORBITS 8
#define MAJORS (1 << MAJORBITS)
#define MINORS (1 << MINORBITS)

It defined major device number and minor device number as 8 bit, but 
now
major device number is 12 bit and minor device is 20 bit.
----------------------------------------------------------------------

Since I didn’t find any information about this aspect in homepage of 
this
package, I wonder whether the latest version has completed the device 
number
extension? If not, will it be completed in the future? And when?


Version-Release number of selected component (if applicable):
raidtools-1.00.3-7
Comment 1 Doug Ledford 2004-04-22 18:04:36 EDT
Raidtools is deprecated, and in fact most likely won't be part of any
product we release that has a 2.6 kernel (current Fedora excluded,
although it's about to get yanked from there).

Note You need to log in before you can comment on or make changes to this bug.