Bug 115073 - /etc/csh.login sets INPUTRC wrong
Summary: /etc/csh.login sets INPUTRC wrong
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setup   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-06 09:02 UTC by dann
Modified: 2014-03-17 02:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 03:22:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dann 2004-02-06 09:02:03 UTC
Description of problem:
/etc/csh.login sets INPUTRC when it should not. 
It contains this test:
if ( -f $HOME/.inputrc ) then
        setenv INPUTRC /etc/inputrc
endif

the test is obviously backwards, if  $HOME/.inputrc does NOT exist
then INPUTRC should be set to /etc/inputrc

This seems to have been around since at least RH-7 ... 


Version-Release number of selected component (if applicable):
setup-2.5.27-1.1

How reproducible:
always

Steps to Reproduce:
1.chsh to csh or tcsh
2. touch ~/.inputrc
3. log on, and then do: 
 echo $INPUTRC                                                          
  
Actual results:
It will print:
/etc/inputrc

Expected results:
nothing should be printed, INPUTRC should not be set

Additional info:

Comment 1 Bill Nottingham 2004-05-05 03:22:25 UTC
Fixed in 2.5.32-1.


Note You need to log in before you can comment on or make changes to this bug.