Bug 1150754 - nodes.conf is blank by default, but the config loader does not have defaults for at least one setting
Summary: nodes.conf is blank by default, but the config loader does not have defaults ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: nodes
Version: Master
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Jeff Ortel
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-08 21:09 UTC by Randy Barlow
Modified: 2015-02-28 22:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:39:07 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 573 0 None None None Never

Description Randy Barlow 2014-10-08 21:09:20 UTC
Description of problem:
I noticed today that I could not run pulp-dev.py -I because my nodes.conf has the ca_path setting commented out.

Version-Release number of selected component (if applicable):
master

How reproducible:
Every time.

Steps to Reproduce:
1. Comment out all of nodes.conf.
2. Run sudo ./pulp-dev -I

Actual results:
<snip>
Traceback (most recent call last):
  File "<string>", line 2, in <module>
  File "/home/rbarlow/devel/pulp/nodes/common/pulp_node/resources.py", line 43, in node_configuration
    cfg.validate(NODE_SCHEMA)
  File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 296, in validate
    return v.validate(self)
  File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 360, in validate
    s.validate(section)
  File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 476, in validate
    self.validproperty(section, property)
  File "/home/rbarlow/devel/pulp/common/pulp/common/config.py", line 494, in validproperty
    raise pe
pulp.common.config.PropertyNotFound: Required property "main.ca_path", not found

Expected results:
The ca_path should be allowed to be undefined in nodes.conf.

Comment 1 Jeff Ortel 2014-10-13 20:19:59 UTC
So far, I cannot reproduce on master or 2.5-dev.  Randy, can you attach your nodes.conf?

Comment 2 Brian Bouterse 2015-02-28 22:39:07 UTC
Moved to https://pulp.plan.io/issues/573


Note You need to log in before you can comment on or make changes to this bug.