Bug 115077 - Compile error: desktop-printing-0.1.10-20, lpegg.c:82
Summary: Compile error: desktop-printing-0.1.10-20, lpegg.c:82
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 115184 115611 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-06 11:16 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 17:47:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Gyurdiev 2004-02-06 11:16:11 UTC
Compile error: desktop-printing-0.1.10-20, lpegg.c:82
gcc version 3.3.2 20040119 (Red Hat Linux 3.3.2-8)

lpegg.c: In function `popup_about_cb':
lpegg.c:82: warning: dereferencing type-punned pointer will break
strict-aliasing rules
lpegg.c: At top level:
lpegg.c:158: error: syntax error before '*' token
lpegg.c: In function `handle_dbus_message':
lpegg.c:163: error: `data' undeclared (first use in this function)
lpegg.c:163: error: (Each undeclared identifier is reported only once
lpegg.c:163: error: for each function it appears in.)
lpegg.c:165: warning: implicit declaration of function
`dbus_message_get_name'
lpegg.c:165: error: `message' undeclared (first use in this function)
lpegg.c:165: warning: format argument is not a pointer (arg 2)
lpegg.c:166: warning: implicit declaration of function
`dbus_message_has_name'
lpegg.c:166: error: `DBUS_MESSAGE_LOCAL_DISCONNECT' undeclared (first
use in this function)
lpegg.c:170: error: `connection' undeclared (first use in this function)
lpegg.c:177: error: `DBUS_HANDLER_RESULT_ALLOW_MORE_HANDLERS'
undeclared (first use in this function)
lpegg.c: In function `init_dbus':
lpegg.c:185: error: `DBusMessageHandler' undeclared (first use in this
function)
lpegg.c:185: error: `handler' undeclared (first use in this function)
lpegg.c:202: warning: implicit declaration of function
`dbus_message_handler_new'
lpegg.c:203: error: too few arguments to function
`dbus_connection_add_filter'
make[2]: *** [eggcups-lpegg.o] Error 1
make[2]: Leaving directory
`/usr/src/redhat/BUILD/desktop-printing-0.1.10/eggcups-0.0.4'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
`/usr/src/redhat/BUILD/desktop-printing-0.1.10/eggcups-0.0.4'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.14646 (%build)
                                                                     
                                                       
                                                                     
                                                       
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.14646 (%build)

Comment 1 Tim Waugh 2004-02-06 11:18:21 UTC
What version of dbus-devel?

Comment 2 Ivan Gyurdiev 2004-02-06 12:41:14 UTC
dbus-devel-0.20-3 (from Project Utopia - Ximian)


Comment 3 Ivan Gyurdiev 2004-02-08 09:19:32 UTC
Well, if the version is too high, the srpm requires list should say
so. Since it doesn't, that's a bug as I see it.



Comment 4 Tim Waugh 2004-02-08 20:49:15 UTC
It isn't, but I am looking at making the upstream package (eggcups)
compile with 0.20.

Comment 5 Tim Waugh 2004-02-08 20:50:05 UTC
*** Bug 115184 has been marked as a duplicate of this bug. ***

Comment 6 Tim Waugh 2004-02-10 17:47:43 UTC
Fixed upstream; next desktop-printing/cups packages will pick it up.

Comment 7 Tim Waugh 2004-02-16 08:55:59 UTC
*** Bug 115611 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.