Bug 115078 - Is there a reason not to accept printer names that start with a digit?
Is there a reason not to accept printer names that start with a digit?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-06 06:17 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 11:05:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-02-06 06:17:10 EST
Description of problem:
r-c-p does not accept printer names that start with a digit

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.79.2-1

How reproducible:
Always


Steps to Reproduce:
1. Attempt to create a printer names "2floor"

  
Actual results:
It complains with "Invalid name"

Expected results:
r-c-p accepts it.

Additional info:
valid_queue_name in /usr/share/printconf/util/printconf_conf.py
insists on ^[a-zA-Z][-a-zA-Z0-9_]*$
Comment 1 Tim Waugh 2004-02-06 06:19:17 EST
There used to be, but I don't believe there is any longer.
Comment 2 Tim Waugh 2004-04-30 09:04:21 EDT
*** Bug 121772 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.