Bug 115108 - Error when assigning windows print drivers
Error when assigning windows print drivers
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-06 14:05 EST by Nick Pietraniec
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Pietraniec 2004-02-06 14:05:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I am setting up a print server using cups/samba.  Cups has been set up
with raw queues, and the printers have been shared via shares manually
created in smb.conf...  Here is a sample share.  (printer admin is
obtained via winbind)

[printername]
        printable = yes
        printer = printername
        path = /path/to/tmp/dir/
        guest ok = yes
        printer admin = @DOMAIN+ADMIN_GROUP

I've assigned printer drivers via rpcclient

when I connect from a win2k box to set up print driver defaults, I get
an error

What happens...

(from windows)
click Start->Run
\\printservername\
open "printers"
right click printer, click properties

**Expected behavior**
properties dialogue comes up
Click advanced tab
click and set printer defaults
defaults are uploaded to print server

**What happens**
Windows hangs after clicking properties
print server displays the following in /var/log/messages/

lib/util_str.c:safe_strcpy_fn(577) ERROR: NULL dest in safe_strcpy"

I found this..

http://www.mail-archive.com/samba@lists.samba.org/msg32283.html

I believe that I am getting bitten by a bug in Samba 3.0.0 that has
been corrected in 3.0.1, but I have been unable to find Redhat ES rpms
for newer versions of samba to test




Version-Release number of selected component (if applicable):
samba-3.0.0-14.3E

How reproducible:
Always
Comment 1 Mario Schugowski 2004-02-10 05:12:29 EST
We have also the Problem, Samba writes many Log Entry, so that is an 
Problem on Production Machines.

See log /var/log/messages:
Feb 10 11:13:19 aldprn02 smbd[589]: [2004/02/10 11:13:19, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:19 aldprn02 smbd[589]:   ERROR: NULL dest in safe_strcpy
Feb 10 11:13:19 aldprn02 smbd[2935]: [2004/02/10 11:13:19, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:19 aldprn02 smbd[2935]:   ERROR: NULL dest in safe_strcpy
Feb 10 11:13:19 aldprn02 smbd[32563]: [2004/02/10 11:13:19, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:19 aldprn02 smbd[32563]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:19 aldprn02 smbd[32563]: [2004/02/10 11:13:19, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:19 aldprn02 smbd[32563]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:20 aldprn02 smbd[30216]: [2004/02/10 11:13:20, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:20 aldprn02 smbd[30216]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:20 aldprn02 smbd[30696]: [2004/02/10 11:13:20, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:20 aldprn02 smbd[30696]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:20 aldprn02 smbd[30602]: [2004/02/10 11:13:20, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:20 aldprn02 smbd[30602]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:20 aldprn02 smbd[28181]: [2004/02/10 11:13:20, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:20 aldprn02 smbd[28181]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:20 aldprn02 smbd[28181]: [2004/02/10 11:13:20, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:20 aldprn02 smbd[28181]:   ERROR: NULL dest in 
safe_strcpy
Feb 10 11:13:21 aldprn02 smbd[31466]: [2004/02/10 11:13:21, 0] 
lib/util_str.c:safe_strcpy_fn(577)
Feb 10 11:13:21 aldprn02 smbd[31466]:   ERROR: NULL dest in 
safe_strcpy

Why can RedHat not Fix a Bug which is solved since 11/2003 by Samba 
Team in its own SAMABA Packages for Enterprise Customers ? Why we pay 
Money ?

So as an Workaround we will Compile own Samba-3.0.2 packages. Hope 
RedHat will support soon his Samba Packages ...

Bye Mario Schugowski
Gruß an Hr. Kunze und Hr. Rieck
Comment 2 Nick Pietraniec 2004-02-10 10:30:32 EST
I have no idea...  I've built Samba 3.0.2 packages using a modified  
spec file from the Redhat ES source RPM and it's more or less  
working fine.    
 
Hello Redhat.  This isn't some obscure package...  If we wanted to 
muck with building RPMS, we wouldn't be paying for ES   
Comment 3 David Lawrence 2004-02-10 12:18:45 EST
There are RPMs of samba-3.0.2rc1 on 
http://people.redhat.com/fenlason/.samba .  Can you try them and see if 
they resolve your problem.  Note that these are un-qa'd packages of a 
release that is not intended for production use.  If they solve your 
problem, We will attempt to get samba-3.0.2 included in the next
quarterly 
update of Red Hat Enterprise Linux 3. 
Comment 4 Nick Pietraniec 2004-02-11 15:12:44 EST
the 3.0.2rc2 rpms work.
Comment 5 Nick Pietraniec 2004-02-17 16:18:14 EST
Everything seems to work with the new rpms, but now I get errors 
like this... 
 
Feb 16 09:27:56 print smbd[4191]: [2004/02/16 09:27:56, 0] 
smbd/connection.c:register_message_flags(220) 
Feb 16 09:27:56 print smbd[4191]:   register_message_flags: 
tdb_fetch failed 
Feb 16 09:32:09 print smbd[4191]: [2004/02/16 09:32:09, 0] 
smbd/connection.c:register_message_flags(220) 
Feb 16 09:32:09 print smbd[4191]:   register_message_flags: 
tdb_fetch failed 
Feb 16 09:32:09 print smbd[4191]: [2004/02/16 09:32:09, 0] 
smbd/connection.c:register_message_flags(220) 
Feb 16 09:32:09 print smbd[4191]:   register_message_flags: 
tdb_fetch failed 
Feb 16 09:34:00 print smbd[4221]: [2004/02/16 09:34:00, 0] 
lib/util_sock.c:get_peer_addr(948) 
Feb 16 09:34:00 print smbd[4221]:   getpeername failed. Error was 
Transport endpoint is not connected 
Feb 16 09:34:00 print smbd[4221]: [2004/02/16 09:34:00, 0] 
lib/util_sock.c:get_peer_addr(948) 
Feb 16 09:34:00 print smbd[4221]:   getpeername failed. Error was 
Transport endpoint is not connected 
 
I've tried removing the tdb files several times.  I've also tried 
samba versions 3.0.1, 3.0.2, and 3.0.2a with no luck.  I've 
downgraded to 2.2.8a and everything seems to be working fine. 
 
Comment 6 RHEL Product and Program Management 2007-10-19 15:30:28 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.