Bug 115141 - bzip2-devel depends on bzip2 and bzip2-libs, but the latter would suffice
Summary: bzip2-devel depends on bzip2 and bzip2-libs, but the latter would suffice
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: bzip2
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-06 22:22 UTC by Moritz Barsnick
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-02-07 02:19:03 UTC


Attachments (Terms of Use)

Description Moritz Barsnick 2004-02-06 22:22:26 UTC
Description of problem:
The package bzip2-devel depends on both bzip2 and bzip2-libs.

Version-Release number of selected component (if applicable):
1.0.2-10

How reproducible:
always

Steps to Reproduce:
1. rpm -q --requires bzip2-devel
2.
3.
  
Actual results:
bzip2
bzip2-libs (amongst others)

Expected results:
bzip2-libs

Additional info:
The devel package enables use of the library functions, and doesn't 
need any of the binaries found in the base package.
I'm nitpicking here, I know.  ;-)

Comment 1 Jeff Johnson 2004-02-07 02:19:03 UTC
Yes, nit-picking. ;-) It's hardly worth the effort to approach
minimal sets of dependencies on a pkg-by-pkg basis.

OTOH, it's rather easy to look at all pkgs in the distro for
mimimal necessary dependencies.


Note You need to log in before you can comment on or make changes to this bug.