Bug 115161 - five compile time problems
five compile time problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: MagicPoint (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-07 09:16 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.10a-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-08 21:21:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-07 09:16:24 EST
Description of problem:

I just tried to compile package MagicPoint-1.10a-4 from Fedora.

The compiler said

1.

gif.c(204): warning #165: too few arguments in function call

The source code is

                tellAboutImage(name);

But, earlier in the same file

static void
tellAboutImage(name, gifp)
        char *name;
        GifFileType *gifp;
{

Suggest add extra parameter to call.

2.

png.c(47): warning #1011: missing return statement at end of non-void
function "pngIdent"

The source code is

int
pngIdent(char *fullname, char *name) {}

Suggest add return statement, or change return type to void.

3.

xwintoppm.c(607): remark #1011: missing return statement at end of
non-void function "Window_Dump"

Source code is

    XDestroyImage(image);
}

Suggest change return type to void.

4.

xwintoppm.c(732): remark #1011: missing return statement at end of
non-void function "_swapshort"
xwintoppm.c(753): remark #1011: missing return statement at end of
non-void function "_swaplong"

Duplicates. Suggest also use ISO C function definition, not 
fifteen year old K&R C.

5.

dsimple.c(506): remark #1011: missing return statement at end of
non-void function "outl"

Another function that looks like it ought to have void return type.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2004-02-08 21:21:22 EST
Fixed in 1.10a-6, which will be available soon

Note You need to log in before you can comment on or make changes to this bug.