Bug 115163 - too many parameters ?
Summary: too many parameters ?
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: memprof   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-07 14:20 UTC by d.binderman
Modified: 2014-06-18 09:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 04:50:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-02-07 14:20:08 UTC
Description of problem:

I just tried to compile package memprof-0.5.1-3 from Fedora.

The compiler said

1.

memintercept.c(438): warning #140: too many arguments in function call

The source code is

        if (!check_init ("__libc_realloc"))

but, earlier in the file

static int
check_init ()
{

I'm not sure what a good fix for this would be.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 John Thacker 2006-04-22 04:50:04 UTC
It's a warning, not a bug or error.  Not going to patch upstream source to
eliminate a harmless warning.


Note You need to log in before you can comment on or make changes to this bug.