Bug 115194 - 3 * missing return + 1 * printf problem
3 * missing return + 1 * printf problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nvi-m17n (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 05:56 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 01:26:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-08 05:56:41 EST
Description of problem:

I just tried to compile package nvi-m17n-1.79-20011024.15 from Fedora.

The compiler said

1.

../common/multibyte.c(801): warning #1011: missing return statement at
end of non-void function "multi_predict_iso2022jp3"

The source code is

static int
multi_predict_iso2022jp3(sp, p, len)
        SCR *sp;
        CHAR_T *p;
        size_t len;
{
        int ret;

        ret = multi_predict_iso2022(sp, p, len);
}

Looks like a missing return statement to me.

2.

../common/multi_canna.c(393): warning #1011: missing return statement
at end of
non-void function "canna_modelinesw"

The source code is

int
canna_modelinesw(sp, x)
        SCR *sp;
        int x;
{
        cannastate.modelinesw = x;
}

Looks like another missing return statement to me.

3.

../common/multi_iso2022.c(1241): warning #1011: missing return
statement at end
of non-void function "iso2022jp_recommendation"

The source code is

int
iso2022jp_recommendation(cs, e)
        CHARSET const *cs;
        ENCODING const *e;
{
        if (cs == NULL)
                return 0;

        switch (cs->type) {
        case CS94:
        case CS9494:
                return 0;
        case CS96:
        case CS9696:
                return 2;
        }
}

Looks like a missing return statement, or a missing default in the switch.

4.

../vi/vs_msg.c(186): warning #268: the format string ends before this
argument

The source code is

                (void)ex_printf(sp,
                    "%s\n", m1 == NULL? "" : m1, m2 == NULL ? "" : m2);

One % specifier, two parameters.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2004-02-09 01:26:26 EST
Fixed in 1.79-20011024.17, which will be avilable soon

Note You need to log in before you can comment on or make changes to this bug.