Bug 115197 - evolution 1.5.2 to 1.5.3 crashes on start (Migrating LDAP servers)
evolution 1.5.2 to 1.5.3 crashes on start (Migrating LDAP servers)
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 10:01 EST by lupus
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 17:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump - about crash (1.55 KB, text/plain)
2004-02-23 16:40 EST, andrej
no flags Details

  None (edit)
Description lupus 2004-02-08 10:01:58 EST
Description of problem:
After update 1.5.2 to 1.5.3.
Everytime I startup evolution it tries to migrating my config
it crashes on Migrating LDAP servers I think.

Now it is impossible to read my e-mail :(

Version-Release number of selected component (if applicable):
evolution-1.5.3-1

How reproducible:


Steps to Reproduce:
1.open evolution
2.
3.
  
Actual results:
crash

Expected results:
evolution with all my e-mails and config

Additional info:
Backtrace was generated from '/usr/bin/evolution'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -1207881600 (LWP 10318)]
[New Thread 74570672 (LWP 10329)]
[Thread debugging using libthread_db enabled]
[New Thread -1207881600 (LWP 10318)]
[New Thread 74570672 (LWP 10329)]
[Thread debugging using libthread_db enabled]
[New Thread -1207881600 (LWP 10318)]
[New Thread 74570672 (LWP 10329)]
[New Thread 57531312 (LWP 10328)]
[New Thread 47041456 (LWP 10324)]
[New Thread 27593648 (LWP 10323)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...0x005b9a52 in _dl_sysinfo_int80 () from
/lib/ld-linux.so.2
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0083294b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x054898f4 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x08063581 in e_user_creatable_items_handler_get_type ()
#4  <signal handler called>
#5  0x00648118 in strcmp () from /lib/tls/libc.so.6
#6  0x05ae0d7c in e_source_list_peek_group_by_uid ()
   from /usr/lib/libedataserver.so.3
#7  0x05ae015a in e_source_group_to_xml () from
/usr/lib/libedataserver.so.3
#8  0x0532a721 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
#9  0x053167a7 in gconf_listeners_remove_if () from
/usr/lib/libgconf-2.so.4
#10 0x0531692d in gconf_listeners_remove_if () from
/usr/lib/libgconf-2.so.4
#11 0x0532a835 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
#12 0x0532a904 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
#13 0x0532a598 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
#14 0x00ae7213 in g_timeout_add () from /usr/lib/libglib-2.0.so.0
#15 0x00ae446d in unblock_source () from /usr/lib/libglib-2.0.so.0
#16 0x00ae5538 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#17 0x00ae5870 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#18 0x00ae5add in g_main_context_iteration () from
/usr/lib/libglib-2.0.so.0
#19 0x003b7045 in gtk_main_iteration () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x01a70e8e in addressbook_config_create_new_source ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
#21 0x01a71f40 in addressbook_config_create_new_source ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
#22 0x01a723f1 in addressbook_migrate ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
#23 0x01a6d625 in ?? ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
#24 0x09424580 in ?? ()
#25 0x00000001 in ?? ()
#26 0x00000005 in ?? ()
#27 0x00000002 in ?? ()
#28 0x09375df8 in ?? ()

Thread 5 (Thread 27593648 (LWP 10323)):
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0082f244 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x00a1331d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x00a13bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0082c5fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006ae89a in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 4 (Thread 47041456 (LWP 10324)):
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0082f244 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x00a1331d in e_msgport_wait () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#3  0x00a13bbd in e_thread_busy () from
/usr/lib/evolution/1.5/libeutil.so.0
No symbol table info available.
#4  0x0082c5fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#5  0x006ae89a in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 3 (Thread 57531312 (LWP 10328)):
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0082f244 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x00ae4b5d in g_main_context_wait () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00ae5f78 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x052c5248 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#5  0x055815f9 in e_book_get_addressbooks () from /usr/lib/libebook.so.3
No symbol table info available.
#6  0x0082c5fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#7  0x006ae89a in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 2 (Thread 74570672 (LWP 10329)):
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x006a5217 in poll () from /lib/tls/libc.so.6
No symbol table info available.
#2  0x00ae64b6 in g_main_loop_get_context () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00ae57f0 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00ae5fd1 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x05275bf2 in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#6  0x00afd85d in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x0082c5fc in start_thread () from /lib/tls/libpthread.so.0
No symbol table info available.
#8  0x006ae89a in clone () from /lib/tls/libc.so.6
No symbol table info available.

Thread 1 (Thread -1207881600 (LWP 10318)):
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x0083294b in __waitpid_nocancel () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x054898f4 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  0x08063581 in e_user_creatable_items_handler_get_type ()
No symbol table info available.
#4  <signal handler called>
No symbol table info available.
#5  0x00648118 in strcmp () from /lib/tls/libc.so.6
No symbol table info available.
#6  0x05ae0d7c in e_source_list_peek_group_by_uid ()
   from /usr/lib/libedataserver.so.3
No symbol table info available.
#7  0x05ae015a in e_source_group_to_xml () from
/usr/lib/libedataserver.so.3
No symbol table info available.
#8  0x0532a721 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
No symbol table info available.
#9  0x053167a7 in gconf_listeners_remove_if () from
/usr/lib/libgconf-2.so.4
No symbol table info available.
#10 0x0531692d in gconf_listeners_remove_if () from
/usr/lib/libgconf-2.so.4
No symbol table info available.
#11 0x0532a835 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
No symbol table info available.
#12 0x0532a904 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
No symbol table info available.
#13 0x0532a598 in gconf_client_change_set_from_current ()
   from /usr/lib/libgconf-2.so.4
No symbol table info available.
#14 0x00ae7213 in g_timeout_add () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#15 0x00ae446d in unblock_source () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#16 0x00ae5538 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#17 0x00ae5870 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#18 0x00ae5add in g_main_context_iteration () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#19 0x003b7045 in gtk_main_iteration () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0x01a70e8e in addressbook_config_create_new_source ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
No symbol table info available.
#21 0x01a71f40 in addressbook_config_create_new_source ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
No symbol table info available.
#22 0x01a723f1 in addressbook_migrate ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
No symbol table info available.
#23 0x01a6d625 in ?? ()
   from /usr/lib/evolution/1.5/components/libevolution-addressbook.so
No symbol table info available.
#24 0x09424580 in ?? ()
No symbol table info available.
#25 0x00000001 in ?? ()
No symbol table info available.
#26 0x00000005 in ?? ()
No symbol table info available.
#27 0x00000002 in ?? ()
No symbol table info available.
#28 0x09375df8 in ?? ()
No symbol table info available.
#0  0x005b9a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
Comment 1 andrej 2004-02-23 16:40:10 EST
Created attachment 97963 [details]
dump - about crash
Comment 2 andrej 2004-02-23 16:48:00 EST

-on first start-up of Evolution=I got the wizard to get a first mail
account configured; on everything configured & finished...I give final
confirmation...and Evolution crashes - an error window gives segfault
as the reason; in the background another, unfocused window titled
"Migrating" can be seen for a glympse. 
...and on subsequent attempts to start it, crashes immediately, every
time again.

-on subsequent restart of KDE - getting a message like :" 
 
the program "evolution-alarm-notify" (process 1572) crashed due to a
fatal error.
(Trace/breakpoint trap)"

Note You need to log in before you can comment on or make changes to this bug.