Bug 115200 - Package selection: Show which cd is needed for which package
Package selection: Show which cd is needed for which package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
FC3 maybe
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 11:18 EST by Steffen Schramm
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 14:58:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen shot of GUI enhancement to /usr/share/comps-extra/whichcd.py (168.34 KB, image/png)
2004-08-10 12:30 EDT, Greg Morgan
no flags Details
Shell script to run GUI enhanced version of whichcd.py (112 bytes, text/plain)
2004-08-10 12:34 EDT, Greg Morgan
no flags Details
GUI and CLI, command line interface, of whichcd. (6.14 KB, text/plain)
2004-08-10 12:36 EDT, Greg Morgan
no flags Details
GUI and CLI, command line interface, of whichcd. (9.04 KB, text/plain)
2004-08-10 13:02 EDT, Greg Morgan
no flags Details

  None (edit)
Description Steffen Schramm 2004-02-08 11:18:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031114

Description of problem:
On package selection menu, for each group/package there should be a
note which cd is needed for it. So users can decide which packages to
select before they get the dialog saying "You'll need CD1, 2 and 3 to
continue"

Assume user downloads CD 1 and 2, because there is most important
software. Then on package selection he selects the groups and packages
he likes, and gets information "You need CD 1 to 3". But he doesnt
have CD 3. He also doesnt want do deselect everything to find out
which of his packages is on CD 3.

If this is to complicated: Another solution would be: On start of
installation, user could be asked which CD he has available, and then
automatically disable all groups/packages which he will not be able to
install anyway because he didn't download the CD.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do not download all 3 CDs
2. Select packages on installation for which you don't have the CD
because you don't know.
    

Additional info:
Comment 1 Jeremy Katz 2004-04-15 00:55:24 EDT
We're string frozen now... will consider for a future release
Comment 2 Greg Morgan 2004-08-10 12:30:47 EDT
Created attachment 102577 [details]
Screen shot of GUI enhancement to /usr/share/comps-extra/whichcd.py
Comment 3 Greg Morgan 2004-08-10 12:34:05 EDT
Created attachment 102578 [details]
Shell script to run GUI enhanced version of whichcd.py

Download this script into /tmp.  Next patch will be the python code that you
will also download into /tmp.
Comment 4 Greg Morgan 2004-08-10 12:36:28 EDT
Created attachment 102579 [details]
GUI and CLI, command line interface, of whichcd.

Download into /tmp.  You will also need file 102578 to execute the script.  The
PYTHONPATH has to be set via 102578.
Comment 5 Greg Morgan 2004-08-10 13:02:55 EDT
Created attachment 102581 [details]
GUI and CLI, command line interface, of whichcd.

Sorry attachment 102579 [details] was an earlier version.

Download into /tmp.  You will also need file 102578 to execute the script.  The

PYTHONPATH has to be set via 102578.
Comment 6 Greg Morgan 2004-08-10 13:09:53 EDT
I was looking at the list of anaconda bugs to see if I could pitch in
on Fedora.  Although this is not what Steffen had in mind it may have
a useful purpose.  In a similar vain, I was trying to locate the rpm
for a package that was not installed initially.  I finally found the
rpm after some hunting.  While looking at anaconda I found whichcd. 
It does what I want.  I thought with some additional enhancements it
could be used without running the installer to find a list of CDs. 
With a GUI  interface, the enhanced version of whichcd might then be
located on fedora hat> system tools menu.  But before I go any further
I'd like some guidance from Red Hat.  The file menu of the new app
allows the /usr/share/comps/i386/hdlist to be exported.  If an xml or
html file is exported how should this file look so that it fits in
with other fedora web files?  Anaconda would still need to be modified
for Steffen's RFE but an html file viewed ahead of install time may
help determine the number of ISOs to download.   Also note the cli
version is still supported.  Finally, there are still several bugs
that I need to fix depending on feedback.  Output with no arguments
pass is
[drkludge@kids drkludge]$ ./whichcd.sh
/tmp/whichcd.py <gui|cli> [package] [headerlist]
where <gui|cli> is the program interface.
         cli is the original command line interface while
         gui is the new graphical user interface
[package] is optionally the package you're looking for
         [package] is not required for gui but required for cli and
[headerlist] is optionally the location of the header list
         (defaults to the one in /usr/share/comps)

Note You need to log in before you can comment on or make changes to this bug.