Bug 115210 - lsraid does not see physical drives.
lsraid does not see physical drives.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: raidtools (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-08 22:53 EST by Sam Varshavchik
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 10:36:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2004-02-08 22:53:57 EST
Description of problem:

Attempted to install test-1 onto a pair of disks in a RAID-1
configuration:

Disk /dev/sda: 36.7 GB, 36703934464 bytes
255 heads, 63 sectors/track, 4462 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1        22    176683+  fd  Linux raid autodetect
/dev/sda2            23      4331  34612042+  fd  Linux raid autodetect
/dev/sda3          4332      4462   1052257+  fd  Linux raid autodetect

Disk /dev/sdb: 36.7 GB, 36703934464 bytes
255 heads, 63 sectors/track, 4462 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/sdb1   *         1        22    176683+  fd  Linux raid autodetect
/dev/sdb2            23      4331  34612042+  fd  Linux raid autodetect
/dev/sdb3          4332      4462   1052257+  fd  Linux raid autodetect

The RAID configuration is straightforward:

RAID-1, /dev/md0: /dev/sda1 + /dev/sdb1

RAID-1, /dev/md1: /dev/sda2 + /dev/sdb2

RAID-1, /dev/md2: /dev/sda3 + /dev/sdb3

As far as I can tell, 0.96 was succesfully installed, and all RAID
volumes are working correctly, including booting off a RAID volume.

The problem is that lsraid seems to be reporting an error:
[root@commodore rhn]# lsraid -a /dev/md0
lsraid: Unable to find superblock for "/dev/sda1": Invalid argument
lsraid: Unable to find superblock for "/dev/sdb1": Invalid argument
[dev   9,   0] /dev/md0         00000000.00000000.00000000.00000000 online
[dev   ?,   ?] (unknown)        00000000.00000000.00000000.00000000
missing
[dev   ?,   ?] (unknown)        00000000.00000000.00000000.00000000
missing

Ditto for md1 and md2.

Version-Release number of selected component (if applicable):

raidtools-1.00.3-6

How reproducible:

Always.

Steps to Reproduce:
1. Install 0.96 onto a RAID volume.
2. Run 'lsraid'
Comment 1 Doug Ledford 2004-07-28 10:36:18 EDT
I believe raidtools has already been pulled from FC, and I *know* that
it has been pulled from RHEL4.  Closing as WONTFIX since raidtools is
deprecated.

Note You need to log in before you can comment on or make changes to this bug.