Bug 115214 - perl -MCPAN -e 'install Data::Dump' ---- Fails
perl -MCPAN -e 'install Data::Dump' ---- Fails
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 00:54 EST by Anshul Gupta
Modified: 2007-04-18 13:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 06:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anshul Gupta 2004-02-09 00:54:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.23; Mac_PowerPC)

Description of problem:
Works with RHL 8.0 and perl-5.8.0-55. 

Version-Release number of selected component (if applicable):
perl-5.8.0-88.3

How reproducible:
Always

Steps to Reproduce:
1.  perl -MCPAN -e shell       (To configure CPAN) 
2.  perl -MCPAN -e 'install Data::Dump'   (To download and install Data:Dump)

    

Actual Results:  Failed in test regexp 

-----------------OUTPUT-------------------------
t/regexp........Can't parse Regexp) at /usr/local/src/cpan/build/Data-Dump-1.02/
blib/lib/Data/Dump.pm line 118.
t/regexp........dubious                                                      
        Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED test 1
        Failed 1/1 tests, 0.00% okay
---------------END OF OUTPUT----------------

Additional info:
Comment 1 Anshul Gupta 2004-02-09 00:55:15 EST
-----------------OUTPUT-------------------------
CPAN: Storable loaded ok
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
  http://www.perl.com/CPAN/authors/01mailrc.txt.gz
Going to read /usr/local/src/cpan/sources/authors/01mailrc.txt.gz
Fetching with LWP:
  http://www.perl.com/CPAN/modules/02packages.details.txt.gz
Going to read /usr/local/src/cpan/sources/modules/02packages.details.txt.gz
  Database was generated on Sun, 08 Feb 2004 19:55:04 GMT

  There's a new CPAN.pm version (v1.76) available!
  [Current version is v1.61]
  You might want to try
    install Bundle::CPAN
    reload cpan
  without quitting the current session. It should be a seamless upgrade
  while we are running...

Fetching with LWP:
  http://www.perl.com/CPAN/modules/03modlist.data.gz
Going to read /usr/local/src/cpan/sources/modules/03modlist.data.gz
Going to write /usr/local/src/cpan/Metadata
Running install for module Data::Dump
Running make for G/GA/GAAS/Data-Dump-1.02.tar.gz
Fetching with LWP:
  http://www.perl.com/CPAN/authors/id/G/GA/GAAS/Data-Dump-1.02.tar.gz
CPAN: Digest::MD5 loaded ok
Fetching with LWP:
  http://www.perl.com/CPAN/authors/id/G/GA/GAAS/CHECKSUMS
Checksum for /usr/local/src/cpan/sources/authors/id/G/GA/GAAS/Data-Dump-
1.02.tar.gz ok
Data-Dump-1.02/
Data-Dump-1.02/README
Data-Dump-1.02/Makefile.PL
Data-Dump-1.02/lib/
Data-Dump-1.02/lib/Data/
Data-Dump-1.02/lib/Data/Dump.pm
Data-Dump-1.02/Changes
Data-Dump-1.02/t/
Data-Dump-1.02/t/regexp.t
Data-Dump-1.02/t/scalar-obj.t
Data-Dump-1.02/t/eval.t
Data-Dump-1.02/t/scalar.t
Data-Dump-1.02/t/dump.t
Data-Dump-1.02/MANIFEST

  CPAN.pm: Going to build G/GA/GAAS/Data-Dump-1.02.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Data::Dump
cp lib/Data/Dump.pm blib/lib/Data/Dump.pm
Manifying blib/man3/Data::Dump.3pm
  /usr/bin/make -j3 -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" 
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/dump..........ok                                                           
t/eval..........ok                                                           
t/regexp........Can't parse Regexp) at /usr/local/src/cpan/build/Data-Dump-1.02/
blib/lib/Data/Dump.pm line 118.
t/regexp........dubious                                                      
        Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED test 1
        Failed 1/1 tests, 0.00% okay
t/scalar-obj....ok                                                           
t/scalar........ok                                                           
Failed Test Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/regexp.t   255 65280     1    1 100.00%  1
Failed 1/5 test scripts, 80.00% okay. 1/22 subtests failed, 95.45% okay.
make: *** [test_dynamic] Error 29
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force


------------------END OF OUTPUT---------------------------------
Comment 2 Chip Turner 2004-02-16 17:45:49 EST
can you test with the perl in rawhide?  it fixes a number of utf8
issues (though may need recompiled for rhl9)
Comment 3 Leonard den Ottolander 2004-04-21 13:45:33 EDT
Anshul, is this fixed in RawHide?
Comment 4 Warren Togami 2005-09-11 06:37:26 EDT
closing due to lack of activity, and we also don't support CPAN

Note You need to log in before you can comment on or make changes to this bug.