Bug 115220 - error behavior for virtual host not taken in account, if not english environment
error behavior for virtual host not taken in account, if not english environment
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-httpd (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 122845 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 05:04 EST by jean-claude jouffre
Modified: 2015-03-04 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-30 11:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jean-claude jouffre 2004-02-09 05:04:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; fr; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
bugs occur when working in a non english environment (e.g. French) and
creating a virtual host :
- after modification of Error pages (in 'site configuration' window),
English and non-English terms are mixed in the error code list
- the generated httpd.conf file always contain :
<VirtualHost *:80>
   ErrorDocument 401 file:
   ErrorDocument 402 file:
...
   ErrorDocument 423 file:
instead of what we have choosen previously
it occurs because of English hard-coding in programs (see additional info)

Version-Release number of selected component (if applicable):
1.1.0-4

How reproducible:
Always

Steps to Reproduce:
1. YOU HAVE TO WORK IN A NON-ENGLISH ENVIRONMENT !!
2. open virtual host window
3. select 'site configuration' on the left
4. select an error page then click on modify
5. modify, e.g. from default to file
6. the list is mixed with english and non-english terms : file and
Fichier (1RST ERROR)
7. valide all screens -> in httpd.conf, bad parameters are always
written : file options with no file (2ND ERROR)
    

Actual Results:  in httpd.conf, bad parameters are always written :
ErrorDocument 401 file:
ErrorDocument 402 file:
...
ErrorDocument 423 file:


Expected Results:  no such parameter if default option was choosen

Additional info:

English hard-coding in programs :
1) /usr/share/redhat-config-httpd/ApacheConf.py
   in on_edit_error_documents_clicked method :
      if behavior == "File" :
   in on_error_document_dialog_clicked_event method :
      clist.set_text (clist.selection [0], 1, "default")
      clist.set_text (clist.selection [0], 1, "File")
2) /usr/share/redhat-config-httpd/ApacheControl.py
   in _hydrate_vhost_page_2 method :
      if value[0:5] == 'file:':
   in _dehydrate_vhost_page_2 method :
      if type == 'default' :
(as I am not a Python expert, I hard-coded in French and it works)
Comment 1 Phil Knirsch 2004-07-30 11:48:07 EDT
OK, i've fixed it using proper gettext() calls. It's not a great fix,
but it works now for every language.

The latest rawhide version s-c-h-1.2.1-1 contains the fix.

Read ya, Phil
Comment 2 Phil Knirsch 2004-08-03 09:55:56 EDT
*** Bug 122845 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.