Bug 11523 - Modem part of Linksys Ethernet modem does not work
Modem part of Linksys Ethernet modem does not work
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-19 10:24 EDT by Yaron Minsky
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-07 08:43:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaron Minsky 2000-05-19 10:24:55 EDT
RH6.2 seems to be having trouble with the modem half of my Linksys
Etherfast LanModem 56k (PCMLM56).  The kernel logs make it look like
everything is coming up OK, but the modem does not respond, either when
accessed via minicom or through an rp3-generated PPP script.

This adapter worked under RH6.1 and continues to work on the same machine
under NT.

**** Diagnostics:

** Debug output from RP3

WvDial: Internet dialer version 1.41
Initializing modem.
Sending: ATZ
Modem not responding.
ERROR: Unable to initialize modem

DIALING FINISHED


** The result of running "test_modem" from the debug_tools directory of the
** PCMCIA distribution:


[root@snapdragon debug-tools]# ./test_modem
Checking modem at /dev/ttyS3:
  Settings: /dev/ttyS3, UART: 16450, Port: 0x0af8, IRQ: 3

At this point, the program freezes.

** The log when the card is inserted.  This looks normal to me.

May 19 10:06:07 snapdragon cardmgr[600]: shutting down socket 0
May 19 10:06:07 snapdragon cardmgr[600]: executing: './network stop eth0'
May 19 10:06:07 snapdragon cardmgr[600]: executing: './serial stop ttyS3'
May 19 10:06:08 snapdragon cardmgr[600]: executing: 'rmmod pcnet_cs'
May 19 10:06:08 snapdragon cardmgr[600]: executing: 'rmmod 8390'
May 19 10:06:08 snapdragon cardmgr[600]: executing: 'rmmod serial_cs'
May 19 10:06:11 snapdragon cardmgr[600]: initializing socket 0
May 19 10:06:11 snapdragon cardmgr[600]: socket 0: Linksys EtherFast
LANmodem 56K
May 19 10:06:12 snapdragon cardmgr[600]: executing: 'insmod
/lib/modules/2.2.14-12/net/8390.o'
May 19 10:06:12 snapdragon cardmgr[600]: executing: 'insmod
/lib/modules/2.2.14-12/pcmcia/pcnet_cs.o'
May 19 10:06:12 snapdragon cardmgr[600]: executing: 'insmod
/lib/modules/2.2.14-12/pcmcia/serial_cs.o'
May 19 10:06:12 snapdragon kernel: eth0: NE2000 Compatible: io 0x300, irq
3, hw_addr 00:E0:98:08:27:6B
May 19 10:06:12 snapdragon kernel: tty03 at 0x0af8 (irq = 3) is a 16450
May 19 10:06:12 snapdragon cardmgr[600]: executing: './network start eth0'
May 19 10:06:13 snapdragon kernel: eth0: found link beat
May 19 10:06:14 snapdragon pumpd[14989]: configured interface eth0
May 19 10:06:14 snapdragon cardmgr[600]: + Determining IP information for
eth0... done.
May 19 10:06:14 snapdragon cardmgr[600]: executing: './serial start ttyS3'
May 19 10:06:15 snapdragon kernel: eth0: found link beat
Comment 1 Yaron Minsky 2000-05-19 11:42:59 EDT
In trying to fix the problems described above, I just installed a newer version
of the PCMCIA susbsytem -- v. 3.1.15.  The problem remains, but now I get some
perhaps slightly more informative log messages.  IN particular, I get the
warning:

   stty: standard input: Inappropriate ioctl for device

Also, I tried the trick suggested in the PCMCIA docs of doing "setserial
/dev/modem irq 0", and it didn't help, either before or after the PCMCIA
upgrade.

Here's the new log file that comes up on a card insert.

May 19 11:37:40 snapdragon cardmgr[17095]: executing: 'modprobe 8390'
May 19 11:37:40 snapdragon cardmgr[17095]: executing: 'modprobe pcnet_cs'
May 19 11:37:40 snapdragon cardmgr[17095]: executing: 'modprobe serial_cs'
May 19 11:37:40 snapdragon kernel: eth0: NE2000 (DL10019 rev 05): io 0x300, irq
3, hw_addr 00:E0:98:08:27:6B
May 19 11:37:40 snapdragon kernel: tty03 at 0x0af8 (irq = 3) is a 16450
May 19 11:37:40 snapdragon cardmgr[17095]: executing: './network start eth0'
May 19 11:37:41 snapdragon cardmgr[17095]: + stty: standard input: Inappropriate
ioctl for device
May 19 11:37:41 snapdragon pumpd[17682]: starting at (uptime 0 days, 2:12:41)
Fri May 19 11:37:41 2000
May 19 11:37:42 snapdragon kernel: eth0: found link beat
May 19 11:37:43 snapdragon pumpd[17682]: configured interface eth0
May 19 11:37:43 snapdragon cardmgr[17095]: + Determining IP information for
eth0... done.
May 19 11:37:43 snapdragon cardmgr[17095]: + stty: standard input: Inappropriate
ioctl for device
May 19 11:37:43 snapdragon cardmgr[17095]: executing: './serial start ttyS3'
May 19 11:37:44 snapdragon kernel: eth0: found link beat
Comment 2 Yaron Minsky 2000-07-07 08:43:10 EDT
I have finally resolved this problem.  The there was an IOPort conflict that
apparently happens not rarely with the linksys card.  The key to noticing the
problem was the observation that the serial port was misdetected as a 16450
instead of a 16550a.  I found the solution on a compo.os.linux.portable post. 
Basically, I had to modify /etc/pcmcia/config.opts.  I changed the file to the
following, and the problem was resolved.

#
# Local PCMCIA Configuration File
#
# System resources available for PCMCIA devices
#
include port 0x100-0x4ff
#include port 0x1000-0x17ff          # causes problem with Linksys PCMLM56
include memory 0xc0000-0xfffff
include memory 0xa0000000-0xa0ffffff, memory 0x60000000-0x60ffffff #
# Extra port range for IBM Token Ring
#
#include port 0xa00-0xaff          # causes problem with Linksys PCMLM56 
 
exclude port 0x230-0x233
exclude port 0x2f8-0x2ff
exclude port 0x12f8-0x12ff
#
# Resources we should not use, even if they appear to be available #
# First built-in serial port
exclude irq 4
# Second built-in serial port
#exclude irq 3
exclude irq 5
# First built-in parallel port
exclude irq 7
# PS/2 Mouse controller port, comment this out if you don't have a PS/2 # based
mouse
exclude irq 12
#
# Examples of options for loadable modules
#
# To fix sluggish network with IBM ethernet adapter...
#module "pcnet_cs" opts "mem_speed=600"
#
# Options for Xircom Netwave driver...
#module "netwave_cs" opts "domain=0x100 scramble_key=0x0" #
# Options for IBM Token Ring adapters
#module "ibmtr_cs" opts "mmiobase=0xd0000 srambase=0xd4000" <
Comment 3 Michael K. Johnson 2000-08-07 23:32:52 EDT
Rather than have us regularily second-guess the pcmcia-cs
maintainer on the best config.opts, I'll count this as
fixed (since you found a fix) and hope that if it is
reasonably possible, future versions of pcmcia-cs will
fix it without breaking anything else...

I'm resolving it as "WONTFIX" not because it will never
be fixed but because I think that the pcmcia-cs maintainer
has more information than we do with which to make appropriate
tradeoffs about how to support the widest variety of
pcmcia cards.

Note You need to log in before you can comment on or make changes to this bug.