Bug 115232 - Installation fails during post-install
Installation fails during post-install
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 09:22 EST by hein
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 17:17:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dump from anaconda (309.23 KB, text/plain)
2004-02-09 09:28 EST, hein
no flags Details
syslog file of installation (16.98 KB, text/plain)
2004-02-09 09:38 EST, hein
no flags Details

  None (edit)
Description hein 2004-02-09 09:22:54 EST
Description of problem: 
After the file transfer phase of the installation of RedHet enterprise Linux the system 
(anaconda) does a post install, which fails and the whole installation is aborted. 
 
Version-Release number of selected component (if applicable): 
anaconda ?????	 
 
How reproducible: 
Happens every time I install on my server (Fujitsu Siemens RX100) 
 
Steps to Reproduce: 
1.Install the system 
2. 
3. 
   
Actual results: 
Installation aborts during post install 
 
Expected results: 
System to be installed with redhat enterprise linux 
 
Additional info: 
Hardware - Fujitsu Siemens computers - RX100 server,  
3.06 GHz Pentium 4 processor 
3GB RAM 
Promise on-board IDE RAID (mirror) 
 
**** Whether installing on a mirror (RAID 0) or single Hard-drive the results 
remain the same. Installation aborts during post install. ****
Comment 1 hein 2004-02-09 09:28:36 EST
Created attachment 97534 [details]
Output of dump from anaconda
Comment 2 hein 2004-02-09 09:38:56 EST
Created attachment 97535 [details]
syslog file of installation

This file was also dumped by anaconda when asked to write a floppy.
Comment 3 Jeremy Katz 2004-02-10 16:24:41 EST
How did you select to set up your network?  It's looking like the
installer's trying to get information from a second network device
that doesn't exist?
Comment 4 hein 2004-02-11 01:10:08 EST
eth0 is setup with a static ip-address and eth1 left unchanged (DHCP). Specified a 
default gateway and nameservers. 
 
However here is some new info: 
 
As stated above the server comes equipt with onboard Promise IDE RAID, which I've 
created a RAID1 (mirror) on using the two 120GB drives in the server, and also one 
IDE chanel for the cdrom. This RAID controler is not supported by Linux during 
install, so the module (driver) for the Promise needs to be loaded at the time of 
booting from cd before install, and other IDE devices should be disabled. so the 
system/kernel dont try to use it. 
 
So I boot with the following string according to documentation: 
boot: linux dd ide0=0x1f0,0x3f6,14 ide1=0x170,0x376,15 ide2=0 ide3=0 ide4=0 
ide5=0 ide6=0 ide7=0 ide8=0 ide9=0 
 
This led me to believe that the systym/kernel will enable ide0 & ide1 and use the 
promise module (ft) to discover drives on that controler, but the system has ONLY 1 
ide interface except for the RAID controler. I then changed the boot string to read as 
follow: 
boot:  linux dd ide0=0x1f0,0x3f6,14 ide1=0 ide2=0 ide3=0 ide4=0 ide5=0 
ide6=0 ide7=0 ide8=0 ide9=0 
 
This sorted the problem. The server now only try to discover one ide chanel instead 
of two. So the problem is sorted. Thanks for the time spent on this. 
Comment 5 Jeremy Katz 2004-02-12 17:17:52 EST
I think that the first string was causing the promise driver to take
over some of the IO ports for your second network card (or something
like that)...  since it doesn't happen outside of the contexts of with
the ft module (which we don't ship or support) and there's a
workaround, I'm going to close for now.

Note You need to log in before you can comment on or make changes to this bug.