Bug 115277 - Input.agent is broken
Summary: Input.agent is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hotplug   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-09 23:37 UTC by W. Michael Petullo
Modified: 2014-03-17 02:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 20:56:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description W. Michael Petullo 2004-02-09 23:37:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.6)
Gecko/20040115 Epiphany/1.0.7

Description of problem:
The file /etc/hotplug/input.agent, installed by the hotplug package,
seems to be broken.  The function input_map_modules () contains the
following:

        matchBits="$2"
                                                                     
          
        bustype="$3"
        vendor="$4"
        product="$5"
        product="$6"
                                                                     
          
        evBits="$7"

Note that product is assigned both $5 and $6.  It looks that $5 should
be assigned to product and $6 should be assigned to version.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I boot and notice that mousedev is not loaded by hotplug for my USB
Logitech Optical Mouse.  I see the following in /var/log/messages:

Feb  9 16:17:01 imp input.agent[3288]: ... no modules for INPUT
product 3/46d/c00e/1110

This is despite the fact that I have the following modules.inputmap:

mousedev 0x0006 0x0000 0x046d 0xc00e [...]

Additional info:

Comment 1 Bill Nottingham 2004-05-03 20:56:53 UTC
Should be fixed in 2004_04_01-1.


Note You need to log in before you can comment on or make changes to this bug.