Bug 11530 - Failure to load Xserver
Failure to load Xserver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-19 16:11 EDT by ole.henriksen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-20 08:15:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ole.henriksen 2000-05-19 16:11:21 EDT
This is a copy of a bug report sent to XF86.org. The Xserver startup output
is copied below.

XFree86 Version: 3.3.6


OS: other
    Linux x86 system, Linux operating system 2.2.5-22smp i686 [ELF] (Red
Hat 6.2)

Area: Xserver

Server: XF86_Mach64

Video Card:

ATI Graphics Pro Turbo w. AT&T 20C408 RAMDAC
SuperProbe info: Chipset ATI 88800GX-D
Memory: 2048 KB
RAMDAC: AT&T 20C408; 15/16/24-bit DAC w/clock (with 6-bit wide lookup
tables (or in 6-bit mode))
(programable for 6/8-bit wide lookup tables)
Attached Graphics Coprocessor: Chipset MACH 64; memory 2048 KB

Description:



XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF]
Configured drivers:
  Mach64: accelerated server for ATI Mach64 graphics adaptors (Patchlevel
1)
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keymap: "xfree86(us)" (overrides other XKB settings)
(**) Mouse: type: Microsoft, device: /dev/mouse, baudrate: 1200
(**) Mouse: buttons: 3, 3 button emulation (timeout: 50ms)
(**) Mach64: Graphics device ID: "ATI Graphics Pro Turbo with AT&T 20C408
RAMDAC"
(**) Mach64: Monitor ID: "My Monitor"
(--) Mach64: Mode "640x480" needs hsync freq of 43.27 kHz. Deleted.
(--) Mach64: Mode "1152x864" needs hsync freq of 43.92 kHz. Deleted.
(--) Mach64: Mode "800x600" needs hsync freq of 48.08 kHz. Deleted.
(--) Mach64: Mode "1024x768" needs hsync freq of 48.36 kHz. Deleted.
(--) Mach64: Mode "640x480" needs hsync freq of 53.01 kHz. Deleted.
(--) Mach64: Mode "1152x864" needs hsync freq of 53.51 kHz. Deleted.
(--) Mach64: Mode "800x600" needs hsync freq of 55.84 kHz. Deleted.
(--) Mach64: Mode "1024x768" needs hsync freq of 56.48 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 51.02 kHz. Deleted.
(--) Mach64: Mode "800x600" needs hsync freq of 64.02 kHz. Deleted.
(--) Mach64: Mode "1024x768" needs hsync freq of 62.50 kHz. Deleted.
(--) Mach64: Mode "1152x864" needs hsync freq of 62.42 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 64.25 kHz. Deleted.
(--) Mach64: Mode "1024x768" needs hsync freq of 70.24 kHz. Deleted.
(--) Mach64: Mode "1152x864" needs hsync freq of 70.88 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 74.59 kHz. Deleted.
(--) Mach64: Mode "1600x1200" needs hsync freq of 75.00 kHz. Deleted.
(--) Mach64: Mode "1152x864" needs hsync freq of 76.01 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 78.86 kHz. Deleted.
(--) Mach64: Mode "1024x768" needs hsync freq of 80.21 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 81.13 kHz. Deleted.
(--) Mach64: Mode "1600x1200" needs hsync freq of 87.50 kHz. Deleted.
(--) Mach64: Mode "1152x864" needs hsync freq of 89.62 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 91.15 kHz. Deleted.
(--) Mach64: Mode "1600x1200" needs hsync freq of 93.75 kHz. Deleted.
(--) Mach64: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) Mach64: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) Mach64: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) Mach64: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
(--) Mach64: Mode "320x240" needs hsync freq of 39.38 kHz. Deleted.
(--) Mach64: Mode "400x300" needs hsync freq of 48.08 kHz. Deleted.
(--) Mach64: Mode "480x300" needs hsync freq of 39.56 kHz. Deleted.
(--) Mach64: Mode "480x300" needs hsync freq of 48.00 kHz. Deleted.
(**) FontPath set to
"/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/u
sr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/l
ib/X11/fonts/75dpi/"
(--) Mach64: Mach64 GX rev 1, Aperture @ 0x00000000, Sparse I/O @ 0x02ec
(--) Mach64: Card type: ISA
(--) Mach64: Memory type: DRAM (0)
(--) Mach64: Clock type: ATI18818-1/ICS2595
(--) Mach64: Maximum allowed dot-clock: 135.000 MHz
(**) Mach64: Mode "640x480": mode clock =  31.500
(**) Mach64: Mode "800x600": mode clock =  40.000
(**) Mach64: Mode "1024x768": mode clock =  44.900
(--) Mach64: There is no mode definition named "1280x1024"
(--) Mach64: Removing mode "1280x1024" from list of valid modes.
(--) Mach64: Virtual resolution: 1024x768
(--) Mach64: Video RAM: 2048k
(--) Mach64: Using hardware cursor
(--) Mach64: Using 4 MB aperture @ 0x04000000
(--) Mach64: Ramdac is AT&T20C408
(--) Mach64: Ramdac speed: 135 MHz
(--) Mach64: Using 8 bits per RGB value
xinit:  Resource temporarily unavailable (errno 11):  unexpected signal 1^M


waiting for X server to shut down .(--) Mach64: Pixmap cache: 2 256x256
slots, 8 128x128 slots, 32 64x64 slots
(--) Mach64: Font cache: 16 fonts
System: `/usr/X11R6/lib/X11/xkb/xkbcomp -w 1 -R/usr/X11R6/lib/X11/xkb -xkm
-m us -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> "
-eml "Errors from xkbcomp are not fatal to the X server" keymap/xfree86
compiled/xfree86.xkm'
.........
 ^M
xinit:  X server slow to shut down, sending KILL signal.

waiting for server to die


Repeat By:

XF86 3.3.6
Linux 2.2.5-22smp i686 [ELF], Red Hat Linux 6.2
I had to instal Linux in text format because my video card/monitor? was not
recognized
I tried several times, unsuccessfully, to use the Xserver setup screens
provided with Red Hat linux.
I gave up on that, then
I logged in as root
cd /usr/X11R6
xf86config
After keyboard and mouse info
I entered graphics card info listed above
My monitor is AcerView 34T (14 inches). According to specs received from
manufacturer, resolution (preset mode) is 640x480/60 Hz, 640x400/70 Hz,
640x350/70 Hz, 640x480/72 Hz, 800x600/60 Hz, 800x600/72 Hz, 1024x768/60 Hz,
non-interlaced
Horizontal freq. 31.5/37.8/48.09/48.3 KHz
Vert. freq. 50~100
I selected horiz. 31.5-37.9 and vertical 50-100
I selected the server Mach64
I copied the XF86Config file to /usr/X11R6/lib/X11
startx
Monitor froze and showed regularly spaced vertical lines (pinkish) w. some
heavier "blobs" on some of them.
Comment 1 Preston Brown 2000-09-11 13:39:26 EDT
the first error seems to indicate some problem with /var/tmp directory that xkb
needs to write to during X startup.  We know that this chipset works fine, so
there is something specific to your system that is incorrectly configured or
malfunctioning.

Are you sure you are not out of disk space?
Comment 2 Mike A. Harris 2001-04-02 15:26:31 EDT
Cannot reproduce in 6.2 or latest rawhide.

Note You need to log in before you can comment on or make changes to this bug.