Bug 115345 - need to whitelist IBM ESS to be scanned beyond LUN 0 by SCSI subsystem
need to whitelist IBM ESS to be scanned beyond LUN 0 by SCSI subsystem
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Don Howard
:
Depends On:
Blocks: 116726 116727
  Show dependency treegraph
 
Reported: 2004-02-10 18:42 EST by Martin Peschke
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 00:31:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that whitelists IBM ESS (544 bytes, patch)
2004-02-10 18:45 EST, Martin Peschke
no flags Details | Diff

  None (edit)
Description Martin Peschke 2004-02-10 18:42:15 EST
Description of problem:
The IBM Enterprise Storage Server (aka Shark) has not been scanned
beyond LUN 0, although max_scsi_luns had been set appropriately in
/etc/modules.conf.

Version-Release number of selected component (if applicable):
2.4.21-9.EL

How reproducible:
100%

Steps to Reproduce:
1. Load zfcp driver with module parameter "map=" containing more than
one FCP device address mapping, which make scsi_mod scan entire busses.
2.
3.
  
Actual results:
cat /proc/scsi/scsi -> only LUN 0 was detected

Expected results:
All LUNs specified in zfcp's "map=" paramter should be detected in the
first place.

Additional info:
Manually triggering SCSI device detection by means of
add-single-device works for each LUN and points out the underlying issue.
Comment 1 Martin Peschke 2004-02-10 18:45:01 EST
Created attachment 97569 [details]
patch that whitelists IBM ESS
Comment 2 Pete Zaitcev 2004-02-10 19:01:20 EST
The context is that we specifically asked IBM to whitelist ESS
in RHEL 3 (as opposed to enable sparse LUN scanning globally
in config-s390-generic) on Arjan's insistence.

Doug, do you want me to grab this?
Comment 4 Martin Peschke 2004-02-11 18:03:47 EST
Right, in the course of that discussion Pete's initial request sank
into oblivion. Mea culpa.
(Isn't anybody else at IBM testing this beast? :-\  )
Comment 5 Martin Peschke 2004-04-15 09:46:45 EDT

*** This bug has been marked as a duplicate of 106392 ***
Comment 7 John Flanagan 2004-09-02 00:31:05 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.