Bug 115359 - When exporting documents as CSV, dates are munged.
When exporting documents as CSV, dates are munged.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 07:39 EST by Luke Ross
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 14:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Ross 2004-02-11 07:39:17 EST
gnumeric-1.2.1-1

When files are exported from gnumeric as CSV, any dates in the sheet
are saved as numbers rather than understandable dates. This is
particularly galling when importing a CSV and then exporting it
produces completely different output. The date format exported does
not appear to be understood by other programs. Reproducible every time.

Steps to Reproduce:
1. Open gnumeric
2. Enter some dates, eg: A1=1/1/1970,A2=1/1/1900,A3=23/3/1981,A4=2/2/2004
3. Save the sheet using the text output converter, selecting comma as
the seperator.
  
Actual results:
When opened in vi, results are similar to:
25569
1
29668
38019

Expected results:
Exported data to be in some sort of understandable (ideally
configurable) format, eg:
1970-1-1
1900-1-1
1981-3-23
2004-2-2

Really this needs to be configurable to be able to round-trip files as
closely as possible. This behaviour was not seen under Redhat 8
running gnumeric gnumeric-1.0.9-2 (I haven't tested RH9).
Comment 1 Caolan McNamara 2004-05-13 08:34:21 EDT
Yeah, gnumeric is saving the dates as the number of days since the end
of 1899. The developers of gnumeric are aware of it at
http://bugzilla.gnome.org/show_bug.cgi?id=128936. 

For what its worth calc in OpenOffice doesn't exhibit this behaviour.
Comment 2 Caolan McNamara 2004-07-28 14:59:04 EDT
With at least gnumeric 1.2.12 (FC3) choose file->save as->Text export
(configurable) and click through to "Choose export format" and select
"Preserves Formats" and gnumeric will save the date as it appears on
screen

Note You need to log in before you can comment on or make changes to this bug.