Bug 1153746 - a deployment that fails due to a misconfigured settings file is unrecoverable
Summary: a deployment that fails due to a misconfigured settings file is unrecoverable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rolekit
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-16 17:14 UTC by Dan Mossor [danofsatx]
Modified: 2014-11-18 12:10 UTC (History)
2 users (show)

Fixed In Version: rolekit-0.1.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-18 12:10:01 UTC
Type: Bug


Attachments (Terms of Use)
journal output (2.34 KB, text/plain)
2014-10-16 17:14 UTC, Dan Mossor [danofsatx]
no flags Details
Settings file (198 bytes, text/plain)
2014-10-16 17:15 UTC, Dan Mossor [danofsatx]
no flags Details

Description Dan Mossor [danofsatx] 2014-10-16 17:14:58 UTC
Created attachment 947696 [details]
journal output

Description of problem:
When a role deployment fails due to a typo or otherwise misconfigured settings-file, rolekit is unable to redeploy with a corrected file or decommission the failed deployment.

Version-Release number of selected component (if applicable):
rolekit-0.1.0-2.fc21.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a settings.json file with incorrect information (Place quotes around an INT, have an incorrect IP address for primary_ip)
2. Run 'rolectl deploy --settings-file ./settings.json domaincontroller'
3. When deployment fails with "Error: COMMAND_FAILED: 512".
4. Correct settings.json file.
5. Attempt 'rolectl redeploy --settings.file domaincontroller/1'
6. Attempt 'rolectl decommission domaincontroller/1'

Actual results:
redeploy will fail with "Error: UNKNOWN_SETTING: admin_password"
decommission will fail with "Error: COMMAND_FAILED: 256"

Expected results:
For redeploy, the deployment process should run again and complete.
For decommission, the role and instance should be deleted.

Additional info:
Attaching the journal output and the settings.json file I used.

Comment 1 Dan Mossor [danofsatx] 2014-10-16 17:15:32 UTC
Created attachment 947697 [details]
Settings file

Comment 2 Thomas Woerner 2014-11-13 16:05:38 UTC
There are fixes for this already in rolekit GIT:

Remove instance again if verification of settings failed
https://git.fedorahosted.org/cgit/rolekit.git/commit/?id=1d61920004de07be405061c0e44352bc3e2ec3ff

rolebase, rolectl: New force option for decommission
https://git.fedorahosted.org/cgit/rolekit.git/commit/?id=eae4e203c180a1f5f18db6c957631b2086476776

With the first fix, the instance will be removed again in case of settings failures that can be detected in rolekit. There are also checks in the roles that rolekit can not detect easily, because they are done in deploy. In this case and also other decommission errors, there is a new force option for decommission.

Comment 3 Fedora Update System 2014-11-17 19:53:51 UTC
rolekit-0.1.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rolekit-0.1.2-1.fc21

Comment 4 Fedora Update System 2014-11-18 12:10:01 UTC
rolekit-0.1.2-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.