Bug 115376 - /etc/csh.cshrc does not specify MAIL env var, as does /etc/profile
Summary: /etc/csh.cshrc does not specify MAIL env var, as does /etc/profile
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setup   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-11 16:48 UTC by Scott R. Godin
Modified: 2014-03-17 02:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 03:18:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Scott R. Godin 2004-02-11 16:48:16 UTC
Description of problem:
/etc/csh.cshrc does not specify the value of the MAIL environment
variable, as does /etc/profile for bash

Version-Release number of selected component (if applicable):
setup-2.5.27-1.1

How reproducible:
always

Steps to Reproduce:
1. install fedora core
2. set your shell to tcsh instead of bash
3. fire up xterm, type env | grep -i mail 
  
Actual results:
.. notice the absence of MAIL 

Expected results:
MAIL = /var/spool/mail/$USER

Additional info:

adding the line 

    setenv MAIL "/var/spool/mail/$USER"

to /etc/csh.cshrc solves the problem. This should be accomplished
before the next Fedora Core release, due to the simplicity of the change.

Comment 1 Bill Nottingham 2004-05-05 03:18:43 UTC
Added in 2.5.32-1

Comment 2 Charles R. Anderson 2004-05-05 19:40:11 UTC
The line that was added is Bourne shell syntax, not C Shell syntax:

MAIL=/var/spool/mail/$USER

I see the syntax error on login with tcsh:

MAIL=/var/spool/mail/cra: Command not found.

This needs to be changed to:

setenv MAIL "/var/spool/mail/$USER"

as suggested above.


Comment 3 Nalin Dahyabhai 2004-05-05 19:51:19 UTC
Fixing for 2.5.33-1.


Note You need to log in before you can comment on or make changes to this bug.