Bug 115381 - kernel-unsupported-2.4.21-4.EL missing dependency
Summary: kernel-unsupported-2.4.21-4.EL missing dependency
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-11 18:19 UTC by Landon Curt Noll
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 18:20:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Landon Curt Noll 2004-02-11 18:19:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The kernel-unsupported-2.4.21-4.EL rpm is willing to install
itself on a system that does not have a 2.4.21-4.EL kernel.

I installed RHEL3.1 WS on a laptop that needed a PCMCIA
based network card.  Using the RHEL3 CD's I installed
the kernel-unsupported rpm found on the CD.  The result
was a useless deposit of modules into a different
kernel /lib/modules directory.

Version-Release number of selected component (if applicable):
kernel-unsupported-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1.boot a RHEL3.1 system with a 2.4.21-9.EL kernel only
2.ls /lib/modules   # we only have 2.4.21-9.EL subdir
3.rpm -ivh kernel-unsupported-2.4.21-4.EL.rpm
4.ls /lib/modules   # rpm created 2.4.21-4.EL 
    

Actual Results:  Installed modules for a kernel that is not installed.

Expected Results:  rpm would complain about a missing dependency

Additional info:

Comment 1 Arjan van de Ven 2004-02-11 18:20:31 UTC
this is not a bug.
kernel-unsupported *cannot* REquire: the kernel since you have to be
able to install it before you install the kernel itself (so that
unsupported modules can go into the initrd)


Note You need to log in before you can comment on or make changes to this bug.