Bug 115388 - inconsistent results as root and non-root user
inconsistent results as root and non-root user
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 15:33 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 17:59:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-02-11 15:33:51 EST
Description of problem:

When I enter the command "rpm -qa mozilla*" as the root user, I get a
listing of all the installed packages whose name begins with "mozilla".

When I do the same thing as a non-root user, I get nothing.  However,
if I do "rpm -qa | grep mozilla", I do get the listing of installed
packages.

This is only on the x86_64.  When I do "rpm -qa mozilla*" on a ix86
system (both root and non-root), I get the listing of installed
packages wose name begins with "mozilla".
Comment 1 Jeff Johnson 2004-02-11 17:25:14 EST
Hmmm, odd, very odd.

Can you try rm -f /var/lib/rpm/__db* please? That's the
major difference root vs. non-root, non-root cannot create
shared locks.
Comment 2 Gene Czarcinski 2004-02-11 17:59:12 EST
OK, did the rm -f and then tried "rpm -qa mozilla*" as non-root ...
nothing.  Then I tried it as root and got the "usual" output.

Remember, this works just fine as root or non-root on the i386
(actually dual athlon).

HA!  Found it.

I am running the Mike Harris stuff for .rpmrc and .rpmmacros to do my
rpm building as non-root and I had a couple of mozilla directories in
my path.  The mozilla* was being "expanded" and it could not find any
packages like those.  Doing rpm -qa "mozilla*" worked fine.


Note You need to log in before you can comment on or make changes to this bug.