Bug 115411 - Compile: Error including freetype headers
Compile: Error including freetype headers
Status: CLOSED DUPLICATE of bug 114681
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 20:24 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-02-11 20:24:20 EST
Just another reminder :) 

make  all-recursive
make[1]: Entering directory `/usr/src/redhat/BUILD/fontconfig-2.2.1'
Making all in fontconfig
make[2]: Entering directory
`/usr/src/redhat/BUILD/fontconfig-2.2.1/fontconfig'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory
`/usr/src/redhat/BUILD/fontconfig-2.2.1/fontconfig'
Making all in fc-lang
make[2]: Entering directory
`/usr/src/redhat/BUILD/fontconfig-2.2.1/fc-lang'
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../src -I/usr/include/freetype2   
-O2 -g -pipe -march=athlon -c fc-lang.c
In file included from ../fontconfig/fcfreetype.h:27,
                 from ../src/fcint.h:39,
                 from fc-lang.c:25:
/usr/include/freetype2/freetype/freetype.h:20:2: #error "`ft2build.h'
hasn't been included yet!"
/usr/include/freetype2/freetype/freetype.h:21:2: #error "Please always
use macros to include FreeType header files."
/usr/include/freetype2/freetype/freetype.h:22:2: #error "Example:"
/usr/include/freetype2/freetype/freetype.h:23:2: #error "  #include
<ft2build.h>"
/usr/include/freetype2/freetype/freetype.h:24:2: #error "  #include
FT_FREETYPE_H"
make[2]: *** [fc-lang.o] Error 1
make[2]: Leaving directory
`/usr/src/redhat/BUILD/fontconfig-2.2.1/fc-lang'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/fontconfig-2.2.1'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.32062 (%build)
                                                                     
                                                       
                                                                     
                                                       
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.32062 (%build)
Comment 1 Owen Taylor 2004-04-19 11:47:36 EDT

*** This bug has been marked as a duplicate of 114681 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.