This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 115487 - up2date-nox Crahes unexpectedly while updating packages
up2date-nox Crahes unexpectedly while updating packages
Status: CLOSED DUPLICATE of bug 110254
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 17:54 EST by Justin Churchey
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2004-02-12 17:54:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
When attempting to update my system today with the following packages:

foomatic-3.0.0-21.3.i386
ghostscript-7.07-15.1.i386
 gimp-print-4.2.6-4.i386                         gimp-print-plugin-4.2.6-4
gimp-print-utils-4.2.6-4
hpijs-1.5-4.1.i386
mutt-1.4.1-5.i386
redhat-config-printer-0.6.7
redhat-config-printer-gui

It crashes after saying it is done downloading the last package with
the following traceback:

Traceback (most recent call last):
  File "/usr/sbin/up2date-nox", line 1188, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date-nox", line 766, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date-nox", line 1051, in batchRun
    batch.run()
  File "up2dateBatch.py", line 82, in run
  File "up2dateBatch.py", line 153, in __installPackages
  File "up2date.py", line 619, in installPackages
NameError: global name 'up2dateErros' is not defined


When trying to run it again, I get the following output:
Fetching package list for channel: fedora-core-1...

Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
There was a fatal error communicating with the server. The message was:

An HTTP error occurred:
URL:
http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os/headers/header.info
Status Code: 302
Error Message: The HTTP server returned a redirect error that
wouldlead to an infinite loop.
The last 302 error message was:
Object moved


Version-Release number of selected component (if applicable):
up2date-4.1.16-1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Run up2date-nox -ui --nosig
2.
3.
    

Actual Results:  It crashes after downloading the packages

Expected Results:  Successfully downloads and installs packages.

Additional info:

The servers that I tried to connect to were entirely default.
Comment 1 Kaj J. Niemi 2004-02-13 04:51:14 EST
This is a duplicate of bug #110254. You should consider upgrading your
up2date client.
Comment 2 Miloslav Trmac 2004-02-13 07:19:39 EST

*** This bug has been marked as a duplicate of 110254 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.