Bug 115509 - gnome-terminal incorrectly handles middle-click paste
gnome-terminal incorrectly handles middle-click paste
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 00:26 EST by Elijah Newren
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-05 14:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elijah Newren 2004-02-13 00:26:24 EST
Description of problem:
This is *really* odd.  When I highlight text in some program and then
go to paste into a gnome-termainl via middle click (which is actually
a simultaneous left & right click since I'm using Emulate3Buttons in
X), I instead get the menu from right-clicking.  Once I have done
that, the keyboard input for gnome-terminal is locked until I hit the
left mouse button at which point the selection is pasted (and if I
have "middle" clicked several times in frustration, then suddenly all
my pastes appear upon the first time that I left click afterwards).  I
see this with gnome-terminal.  I do not see it with emacs, Mozilla,
xterm, or gedit.

Version-Release number of selected component (if applicable):
gnome-terminal-2.5.1-1 according to 'rpm -q'

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 2 Test 1
2. Set Emulate3Buttons to yes
3. Highlight some text in *any* program
4. Middle click to paste into a gnome-terminal
  
Actual results:
The menu from right clicking appears instead, although the text has
been "sort-of" pasted (meaning that a subsequent left click will cause
the text to appear).

Expected results:
The text pastes upon middle clicking and the right-click-context-menu
does not appear.

Additional info:
I also have Fedora Core 1 installed on the Laptop on a separate
partition.  I do not see the problem there.  It only shows up with
gnome-terminal on Fedora 2 Test 1.  It's really odd to me too, because
I run Gnome built from CVS on two other machines and I haven't seen
such a problem.  *shrug*  Any other information I can help provide for
you to track this down?
Comment 1 Eugéne Roux 2004-02-23 06:28:00 EST
This is manifested if more than one InputDevice entry pointing to a
mouse exists in XF86Config.

That was required in Kernel 2.4x to support multiple devices (PS/2,
USB and Serial) but now a single entry only is needed.

I made the change by deciding to use only '/dev/input/mice' as opposed
to '/dev/psaux' in addition and all is well again.
Comment 2 Elijah Newren 2004-06-05 14:46:59 EDT
It doesn't happen with Fedora Core 2, so I'm closing.

Note You need to log in before you can comment on or make changes to this bug.