Bug 115520 - system-config-soundcard crashes when running kernel 2.4
system-config-soundcard crashes when running kernel 2.4
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-13 02:29 EST by Alin Osan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-05 15:16:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
soundcard.py (12.32 KB, text/plain)
2004-02-20 10:52 EST, Brent Fox
no flags Details

  None (edit)
Description Alin Osan 2004-02-13 02:29:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
system-config-soundcard crashes with the following error:

(system-config-soundcard:2187): GLib-CRITICAL **: file gstrfuncs.c:
line 2129 (g_strsplit): assertion `string != NULL' failed

(system-config-soundcard:2187): GLib-CRITICAL **: file gstrfuncs.c:
line 2241 (g_strjoinv): assertion `str_array != NULL' failed

** (system-config-soundcard.py:2192): WARNING **: `GtkTextSearchFlags'
is not an enum type
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
48, in ?
    app.stand_alone()
  File "/usr/share/system-config-soundcard/soundcard.py", line 301, in
stand_alone
    self.icon_box.pack_start(self.icon, gtk.FALSE)
AttributeError: childWindow instance has no attribute 'icon'


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2149.nptl system-config-soundcard-1.2.2-1

How reproducible:
Always

Steps to Reproduce:
run the program
    

Actual Results:  crashes

Expected Results:  working condition

Additional info:
Comment 1 Brent Fox 2004-02-19 20:20:28 EST
Can you attach your /usr/share/system-config-soundcard/soundcard.py file?
Comment 2 Brent Fox 2004-02-20 10:52:40 EST
Created attachment 97857 [details]
soundcard.py
Comment 3 Brent Fox 2004-02-20 10:56:31 EST
I don't think this bug has anything to do with which kernel you are
running.  The icon isn't being loaded for some reason.

Look for /usr/share/system-config-soundcard/pixmaps/multimedia.png on
your system.  Does that file exist?  It looks to me like it's been
removed somehow.
Comment 4 Alin Osan 2004-02-20 12:30:33 EST
I though that had something to do with the kernel, but I get the same
error with kernel 2.6. Oddly enough, system-config-printer has a
similar error. I file a bug report for that later.

The file you mentioned seems fine:
[aline@yuer aline]$ file
/usr/share/system-config-soundcard/pixmaps/multimedia.png
/usr/share/system-config-soundcard/pixmaps/multimedia.png: PNG image
data, 48 x 48, 8-bit/color RGBA, non-interlaced
[aline@yuer aline]$
Comment 5 Brent Fox 2004-03-10 15:20:22 EST
I don't know what the problem could be.  system-config-soundcard
starts up just fine for me on my 2.6 FC2 test1 machines.
Comment 6 Brent Fox 2004-03-10 17:14:01 EST
Was this an upgrade or a fresh install?
Comment 7 Brent Fox 2004-08-05 15:16:15 EDT
Closing due to lack of information.

Note You need to log in before you can comment on or make changes to this bug.