Bug 115531 - Automatic variable HOSTTYPE is "unknown" on x86_64
Summary: Automatic variable HOSTTYPE is "unknown" on x86_64
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcsh   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 178252 187539
TreeView+ depends on / blocked
 
Reported: 2004-02-13 10:41 UTC by Göran Uddeborg
Modified: 2010-04-06 10:19 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0218
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 17:04:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0218 normal SHIPPED_LIVE tcsh bug fix update 2006-07-19 18:56:00 UTC

Description Göran Uddeborg 2004-02-13 10:41:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Tcsh automatically sets the environent variable "HOSTTYPE" to "a
symbolic name for the type of computer that it is running on".  The
x86_64 version of tcsh sets this to "unknown".

Version-Release number of selected component (if applicable):
tcsh-6.12-4

How reproducible:
Always

Steps to Reproduce:
1. tcsh -c 'echo $HOSTTYPE'

Actual Results:  unknown

Expected Results:  x86_64, or something like amd64

Comment 1 Miloslav Trmač 2004-08-23 16:01:16 UTC
For x86_64 fixed in rawhide tcsh-6.13-2, still needs fixing
for other RHEL architectures though.

Comment 2 Miloslav Trmač 2004-09-15 16:52:12 UTC
Fixed in tcsh-6.13-8, which should appear in rawhide after FC3t2.


Comment 3 Bastien Nocera 2005-11-04 11:42:11 UTC
$MACHTYPE has the same problem.
Reopening as the problem isn't fixed on RHEL3 itself.

Comment 4 Miloslav Trmač 2005-11-04 12:19:53 UTC
Changing $HOSTTYPE and $MACHTYPE could break existing scripts, I don't think it is
safe to change the values in RHEL3.

Comment 5 David Mair 2005-12-07 23:20:47 UTC
Re-opening this.  Not fixing this is causing scripts to break between x86 and
x86_64 for customers.

Comment 13 Red Hat Bugzilla 2006-03-22 17:04:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0218.html


Comment 15 Kevin Parkes 2006-06-08 13:24:30 UTC
This solution is not working for me. 
The tcsh-6.12-13.EL3.x86_64.rpm isn't available for X86-64 systems via up2date
and the advisory doesn't include links to an altrnative sorce for the rpm. 

Comment 16 Miloslav Trmač 2006-06-08 14:36:05 UTC
The updated package should be available in the fast-track channel, you may need
to subscribe to it in RHN.

It will be published in the standard channel in the next update release.


Note You need to log in before you can comment on or make changes to this bug.