Bug 115559 - RFE: new version available
Summary: RFE: new version available
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 15:44 UTC by Moritz Barsnick
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 21:46:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Moritz Barsnick 2004-02-13 15:44:49 UTC
Description of problem:
A new version of xpdf, namely 3.00, is available.

Version-Release number of selected component (if applicable):
2.03-1

How reproducible:
always

Steps to Reproduce:
1. rpm -q xpdf
2. brwose to http://www.foolabs.com/xpdf/download.html
3.
  
Actual results:
2.03 is packaged.

Expected results:
3.00 is packaged. :-)

Additional info:
Furthermore, t1lib (the source of which is included with the xpdf 
SRPM) has been updated to 5.0.1. "It works for me (TM)." There may be 
some patches required to make it build properly. I'll check my 
"personal" SRPMs later and post here if necessary.

xpdf (any version, I guess) also requires a patch to compile against 
freetype-2.1.7 (a similar patch to the one added in ttmkfdir-3.0.9-8.
src.rpm).

Thanks,
Moritz

Comment 1 Ngo Than 2004-02-15 10:49:22 UTC
i have already built xpdf-3.00 on my local machine. There is a
critical problem in new version. It can not show some pdf files correctly.

I already sent a test pdf to the pdf author.

It would be nice if you could post here your changes please. thanks


Comment 2 Moritz Barsnick 2004-02-17 08:05:28 UTC
Point taken. I have not seen any problems with any files on my build 
though. I've looked at files from various sources, yet the PDF-1.4 
files where "only" created by ghostscript-8.1x. I _do_ get warnings 
in the console about fonts (I think they're referenced in the PDF but 
not embedded - just my guess), but the display is as expected.

Re my patches: Two of them were against t1lib-5.0.0, but are 
obviously obsoleted in 5.0.1. The other one was against xpdf and 
adapted from Debian, and disabled the obeyance of print, selection, 
etc. prohibition (alas only for non-password protected PDFs). You 
don't really want to include that. ;-) (Or do you?) I'll attach the 
workaround patch for freetype-2.1.7 a.s.a.p.

Comment 3 Ngo Than 2004-02-17 11:00:35 UTC
i have already a fix to build against freetype-2.1.7 ;-)

Comment 4 Ngo Than 2004-02-20 21:46:54 UTC
xpdf-3.00 is now available in rawhide.

Comment 5 Bob T. 2004-03-07 14:34:59 UTC
We'd be grateful if you could tell what are the symptoms of the
"critical bug" and whether the bug has been fixed in the current rawhide.


Note You need to log in before you can comment on or make changes to this bug.