Bug 11557 - <scsi/sg.h> has duplicate member in struct sg_io_hdr
Summary: <scsi/sg.h> has duplicate member in struct sg_io_hdr
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-21 19:24 UTC by Jonathan Kamens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-21 21:23:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-05-21 19:24:21 UTC
In file included from sanei_scsi.c:79:
/usr/include/scsi/sg.h:49: duplicate member `dxfer_direction'

Comment 1 Jonathan Kamens 2000-05-21 21:23:59 UTC
Additional errors from this header file:

/usr/include/linux/../scsi/sg.h:130: redefinition of `struct sg_header'
/usr/include/linux/../scsi/sg.h:148: redefinition of `struct sg_scsi_id'
/usr/include/linux/../scsi/sg.h:158: warning: redefinition of `Sg_scsi_id'
/usr/include/scsi/sg.h:211: warning: `Sg_scsi_id' previously declared here

Structures that are defined in Linux kernel header files probably shouldn't be
redefined in glibc header files.

Comment 2 Jakub Jelinek 2000-08-24 10:27:21 UTC
The first thing has been fixed on 05-21, just forgot to update bugzilla.
The second issue is not a bug, you should not be including linux/include/scsi.h
headers in userland applications.


Note You need to log in before you can comment on or make changes to this bug.