Bug 115579 - emu10k1 not working
Summary: emu10k1 not working
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 17:33 UTC by Joerg Skottke
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-23 18:17:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joerg Skottke 2004-02-13 17:33:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Sound doesn't work even if modules appear to be loaded correctly and
the volume is >> 0 on the gnome panel mixer

Module                  Size  Used by
snd_mixer_oss          19072  1
snd_emu10k1           109188  1
snd_rawmidi            29344  1 snd_emu10k1
snd_pcm               112264  1 snd_emu10k1
snd_timer              34436  1 snd_pcm
snd_seq_device          8456  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         61700  1 snd_emu10k1
snd_page_alloc         12036  2 snd_emu10k1,snd_pcm
snd_util_mem            4864  1 snd_emu10k1
snd_hwdep               9476  1 snd_emu10k1
snd                    57828  9
snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_pcm,sn
d_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore              10720  2 snd
md5                     4224  1
ipv6                  262400  8
lp                     12652  0
autofs                 16512  0
3c59x                  39848  0
ohci1394               41860  0
ieee1394              284464  1 ohci1394
sg                     36768  0
sr_mod                 17828  0
cdrom                  37276  1 sr_mod
parport_pc             38444  0
parport                48488  2 lp,parport_pc
uhci_hcd               43024  0
usbcore               114908  3 uhci_hcd
nvidia               2073096  12
ext3                  128296  2
jbd                    86040  1 ext3
aic7xxx               196312  3
sd_mod                 16928  4
scsi_mod              124600  4 sg,sr_mod,aic7xxx,sd_mod



Version-Release number of selected component (if applicable):
kernel 2.6.2-1-74

How reproducible:
Always

Steps to Reproduce:
1. -
2.
3.
    

Actual Results:  system-config-soundcard displays following error:

The snd-emu10k1 driver could not be loaded.  This soundcard may not be
compatible with Red Hat Linux.


Expected Results:  Impressive sound experience.

Additional info:

Comment 1 Alexander Bussman 2004-02-14 14:21:33 UTC
You could try to run: 
amixer set Master 100 unmute 
amixer set Wave 100 unmute 
amixer set PCM 100 unmute 
amixer set CD 100 unmute 
 

Comment 2 Thomas Covello 2004-02-18 21:46:39 UTC
Are you using a Dell Dimension desktop? If so, this bug could be a
dupe of bug 107060.

Comment 3 Joerg Skottke 2004-02-19 07:28:32 UTC
No, i'm afraid not. No dupe.
I have a handcrafted machine (Epox EP8KTA-3 pro board and a
SoundBlaster Live! 1024).

I don't think Alexander's suggestion is helping either since the mixer
applications don't appear to see the soundcard at all (i will try it
today anyway).

But i've noticed that there have been quite a lot of updates to ALSA
and the emuk-driver in the 2.6.3 kernel. I think i will try the new
kernel, maybe the problem is accidentially solved. 

Comment 4 Christian Schaller 2004-02-22 17:46:21 UTC
When running the 'Soundcard detection' applet I am told that it is
unable to load the snd-emu10k1 module. After I ran aumix and adjusted
the sound up from zero it did work, so I think this is a bug in the
capplet not in the alsa installation.

Comment 5 Joerg Skottke 2004-02-23 18:17:37 UTC
I hate to admit it but after applying the amixer settings the
soundcard works. :(

I apologize for the inconvenience.


Note You need to log in before you can comment on or make changes to this bug.