Bug 115585 - creating a new JetDirect print queue gives error message
Summary: creating a new JetDirect print queue gives error message
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-13 17:57 UTC by Bernd Bartmann
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 07:28:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2004-02-13 17:57:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When trying to create a new JetDirect print queue (no other queues
configured yet) to a HP LJ 5M printer I get this error after applying
all changes and waiting for the test page:

Problem while sending CUPS test page to queue 'hplj5m':
lpr: unable to print file: server-error-service-unavailable

After clicking ok and manually selecting the CUPS test page from the
test menu it works.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. setup a new JetDirect printer
2.
3.
    

Additional info:

Comment 1 Tim Waugh 2004-02-18 13:05:06 UTC
How about if you increase the sleep time at line 1159 of
/usr/share/printconf/util/addQueue.py?  It looks like:

                time.sleep (5)

for 5 seconds -- try 15 or something.

Comment 2 Bernd Bartmann 2004-02-18 15:31:44 UTC
Line number is 1291 on my system. Anyway, this seems to fix the problem.

Comment 3 Tim Waugh 2004-02-18 15:43:13 UTC
What's the smallest delay that works?  Does a 10-second delay work,
for instance?  Is this a particularly slow machine?

Comment 4 Bernd Bartmann 2004-02-18 16:50:52 UTC
Weird. Today it sometimes even works with a 5 secs delay, but 10 secs
seems to be always ok.

The machine is a VMware image with bridged networking, 256 MB RAM
running on 3 GHz PIV, 2 GB RAM host system. The VMware sessions feels
indeed a little bit slow compared to a FC1 VMware image.

Comment 5 Tim Waugh 2004-02-18 17:03:08 UTC
I've changed this to 10 seconds in CVS.  Will be picked up by the next
build.


Note You need to log in before you can comment on or make changes to this bug.